How to configure exchange 2007 to only accept email from specific ip adresses?

We are using an external spam filter service for anti-spam and we need to configure the Exchange 2007 to only accept email from the ip addresses of the anti-spam service provider.
UnityTechAsked:
Who is Participating?
 
Glen KnightCommented:
Don't think so.
0
 
Glen KnightCommented:
You need to configure the Receive Connecte under server comfguration > Hub Transport.  Under the network tab specify the IP address you want and remove the others.

Make sure you have the server that accepts your external mail highlighted when you right click on the receive connector.
0
 
UnityTechAuthor Commented:
thanks, thats what I did but wasnt sure if I needed to set it up on the anti-spam option under the hub transport.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
raiterCommented:
You can also configure your firewall to only allow SMTP to/from the IP Addresses listed by your service provider.  This way unwanted connections are blocked at the network level before they even hit your servers.  Also, if you have any SMTP devices like fax machines or logging and alert servers internal to your network, they remain unaffected.
0
 
Alan HardistyCo-OwnerCommented:
I would restrict the IP's on your firewall.  Why bother allowing them through the firewall in the first place for Exchange to reject them?  Block them on your router / firewall instead and save the extra traffic / load on the server.
0
 
Alan HardistyCo-OwnerCommented:
0
 
Glen KnightCommented:
See here for a guide on restructung receive connectors: http://www.msexchange.org/articles_tutorials/exchange-server-2007/management-administration/managing-receive-connectors-part2.html

I agree with the others the firewall is the ideal place to do it.
0
 
Alan HardistyCo-OwnerCommented:
0
 
UnityTechAuthor Commented:
the problem with blocking them on the firewall is that the firewall doesn't have that option available so we needed to restrict them at the exchange server until we install a better firewall.
0
 
Alan HardistyCo-OwnerCommented:
Well, at least you know two ways to achieve the same result.  Receive Connector for now, firewall for later!
0
 
Glen KnightCommented:
Figured the firewall couldn't donut otherwise you wouldn't have been asking for how to do it with Exchange :-)
0
 
raiterCommented:
I had thought of that, but I wondered what firewall doesn't! ;-)
0
 
Alan HardistyCo-OwnerCommented:
Glen - My firewall doesn't donut either!!
0
 
Glen KnightCommented:
Mine too Alan! It's one of those special ones with custard in the middle :-)

that's what happens when your running whilst typing on the iPhone!
0
 
Alan HardistyCo-OwnerCommented:
One day your legs will be so worn down by running you will be able to work as one of Snow White's 7 special men!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.