• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 772
  • Last Modified:

Missing snap-ins from MMC

I recently upgraded the OS on my file server to Windows Server 2008 SP2.  I went to setup an "ADUC Consule" using MMC; however, when I clicked to "add Snap-in", it opened the list of snap-ins, but there were none of the Active Directory snaps (ADUC, etc).

What am I missing so that I can include these snapins?
0
DWStovall
Asked:
DWStovall
1 Solution
 
jaynirCommented:
did you run DCPROMO?
0
 
Mike KlineCommented:
On your file server that is now 2008 add the Remote Server and Admin Tools feature (RSAT)
Jose has a great blog entry showing the different features/roles on a 2008 box
http://blogs.technet.com/josebda/archive/2007/07/24/server-manager-roles-and-features-in-windows-server-2008-beta-3.aspx
Thanks
Mike
0
 
DWStovallAuthor Commented:
jaynir - It is not a Domain Controller.

mkline - RSAT is already a feature.

There is some issue about permissions I think.  I am logging on with a "adm" account which is a member of "Domain Admins", and "Domain Admins" is a member of the local "Administrators" - so I should be able to do everything on the box.  Most often I have to run everything "Run As Administrator" through the "Run" line to get full functionality of certain apps like the File Server Resource Manager.  Otherwise I don't see all of the functions.  Is there a way to make everything work without turning off the UAC?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
beesterCommented:
One thing you could do is start an elevated command prompt, and then start 'mmc' from there. At least then the mmc will start elevated as well, just to check if it's a permission issue.
0
 
DWStovallAuthor Commented:
I have tried both running and elevated command prompt as was as logging in at the local Administrator on the box.  Still no joy...
0
 
DWStovallAuthor Commented:
When I initially looked in the list of features, it showed that the RSAT was already a feature.  Only when I went in to edit the features did I see that only minimal items under the RSAT had been selected.  When I selected the elements of the feature I wanted, and rebooted, the rest of the plugins became available.  The devil is in the details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now