• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 989
  • Last Modified:

How to enable NAT in VMware

I have VMware running and it could access internet and other drives.

Now I noticed that NAT is not available.

How can I make it available again
eeNATerror.jpg
0
rayluvs
Asked:
rayluvs
  • 5
  • 4
1 Solution
 
JohnBusiness Consultant (Owner)Commented:
Go to Start -> Programs -> VMware -> Virtual Network Editor and make sure NAT shows up under VMNet 8. Also make sure it is enabled. See what is there and let us know. ... Thinkpads_User
0
 
rayluvsAuthor Commented:
yes its enable.
0
 
JohnBusiness Consultant (Owner)Commented:
Are you using VMware Workstation? I don't see that screen (VMware 7 and earlier versions). And do you have just one NIC in your guest machine? Should be just one for most guests. ... Thinkpads_User
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
rayluvsAuthor Commented:
its a notebook with windows 7,VMware Server, one nic (notebook's)
0
 
JohnBusiness Consultant (Owner)Commented:
I see some issues trying to run WMware Server on Windows 7. You can try Bridged Mode (instead of NAT) to see if that works. If that works but NAT still isn't available, you could try re-installing VMware Server.

Also, you said you didn't get an Internet connection, but your dialogue box says NAT is not available. Just in case, do not forget that with NAT, you must enable the NAT range on your host firewall. That could be an issue as well. ... Thinkpads_User
0
 
rayluvsAuthor Commented:
the strange thin it was working already in Windows 7.  I installed XP mode virtulization right before any errors; could that be the culprit?
0
 
JohnBusiness Consultant (Owner)Commented:
Hmm, you did not mention that originally. XP Mode Virtualization is an emulator like VMware. That is more than likely the culprit here. Emulators like to run their own NAT (that is how VMware does it). I have Windows 7 Pro running with VMware Workstation 7. I have not installed the XP mode stuff because I already have VMware. I would uninstall the XP Mode Virtualiztion and use VMware itself if you need an XP machine.  ... Thinkpad_User
0
 
rayluvsAuthor Commented:
I tried changing Bridged Mode and worked perfectly!  As a matter of fact, btoh VMware & XP Mode W7 works on the same USB devices.

Thanx
0
 
JohnBusiness Consultant (Owner)Commented:
Thank you. I was pleased to assist you. ... Thinkpads_User
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now