?
Solved

VM Server to ESX conversion problem with USB

Posted on 2010-01-04
2
Medium Priority
?
774 Views
Last Modified: 2013-11-11
I had a VM running on VM server and it worked find but taxed my harddrive so I ran the conversion agent and moved it to ESX.  The first time I attempted to start it I got the error:  "Device usb is not supported. This is a general limiataion of the machines virtual hardware."  

Thats fine I dont need usb on it.  But I cant seem to remove it.   I went in to edit the machine and it would mark usb as removed but not actually do it.   I read on the internets that I could edit the vmx file so I tried that,  I removed everything that mentioned USB, I still get the same error.   This is my VMX file:



.encoding = "UTF-8"
config.version = "9"
virtualHW.version = "8"
vmci0.present = "true"
nvram = "G XP.nvram"
deploymentPlatform = "windows"
virtualHW.productCompatibility = "hosted"
unity.customColor = "|23C0C0C0"
tools.upgrade.policy = "useGlobal"
powerType.powerOff = "soft"
powerType.powerOn = "default"
powerType.suspend = "hard"
powerType.reset = "soft"
displayName = "G XP"
extendedConfigFile = "G XP.vmxf"
humvcpus = "2"
memsize = "768"
ide0:0.present = "true"
ide0:0.fileName = "G XP.vmdk"
ide1:0.present = "true"
ide1:0.fileName = "/dev/scd0"
ide1:0.deviceType = "atapi-cdrom"
ide1:0.startConnected = "false"
ide1:0.allowGuestConnectionControl = "false"
ethernet0.present = "true"
ethernet0.networkName = "Core Network"
ethernet0.addressType = "vpx"
ethernet0.generatedAddress = "00:50:56:a3:4f:d7"
guestOS = "winxppro"
uuid.bios = "42 23 25 24 fc 93 49 2b-c6 73 a4 47 ee b4 7b b6"
vc.uuid = "52 c5 9b ed c9 24 30 fd-24 68 44 58 56 cd e3 41"
sched.cpu.min = "0"
sched.cpu.units = "mhz"
sched.mem.minsize = "0"
ethernet0.features = "1"
vmotion.checkpointFBSize = "134217728"
ethernet0.generatedAddressOffset = "0"
checkpoint.vmState = ""
floppy0.present = "FALSE"


I cant seem to get it to do anything anymore.  Can advise would be welcome.

Thanks,

g
0
Comment
Question by:gmacmaster
2 Comments
 
LVL 29

Expert Comment

by:Michael Worsham
ID: 26175993
Possible solution....

Device 'USB' is not supported after conversion
http://communities.vmware.com/message/1419701
0
 
LVL 24

Accepted Solution

by:
ryder0707 earned 1000 total points
ID: 26177084
Remove the VM from inventory(dont delete from disk)
Delete the vmx file or rename it for backup purposes
Recreate the VM in esx but use existing vmdk(the one you converted)
0

Featured Post

[Webinar On Demand] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If we need to check who deleted a Virtual Machine from our vCenter. Looking this task in logs can be painful and spend lot of time, so the best way to check this is in the vCenter DB. Just connect to vCenter DB(default DB should be VCDB and using…
It’s time for spooky stories and consuming way too much sugar, including the many treats we’ve whipped for you in the world of tech. Check it out!
Teach the user how to use configure the vCenter Server storage filters Open vSphere Web Client:  Navigate to vCenter Server Advanced Settings: Add the four vCenter Server storage filters: Review the advanced settings: Modify the values of the four v…
Teach the user how to use vSphere Update Manager to update the VMware Tools and virtual machine hardware version Open vSphere Client: Review manual processes for updating VMware Tools and virtual hardware versions: Create a new baseline group in vSp…
Suggested Courses

615 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question