[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 693
  • Last Modified:

Setting up ASPX application on IIS - Could not load file or assembly

Hi,

I am trying to setup an an application written in ASPX (c#.net) on our sbs2008 server. It wasnt written by me howver it is currently running on our sbs2003 machine perfectly.

I want to get it working on our sbs 2008 machine.

However I get the attached error. I cant find out why.

I have installed Microsoft Office 2007 as I thought that was a requirement.

Any input is greatly appreciated.

Mitch
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

Parser Error Message: Could not load file or assembly 'Microsoft.VisualStudio.Tools.Applications.Runtime, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

Source Error: 

Line 56:   <add assembly="Infragistics2.WebUI.WebDateChooser.v8.2, Version=8.2.20082.1000, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb" />
Line 57: 	   <add assembly="Microsoft.Office.Interop.Word, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
Line 58:   <add assembly="Microsoft.VisualStudio.Tools.Applications.Runtime, Version=8.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
Line 59:   </assemblies>
Line 60:   </compilation>

Source File: C:\www\web.config    Line: 58 

Assembly Load Trace: The following information can be helpful to determine why the assembly 'Microsoft.VisualStudio.Tools.Applications.Runtime, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' could not be loaded.

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.1434; ASP.NET Version:2.0.50727.1434

Open in new window

0
SM17CH
Asked:
SM17CH
  • 4
  • 3
  • 2
  • +1
3 Solutions
 
zadeveloperCommented:
Try this:

Go to the Advanced settings of the Application pool. and set the option: Enable 32 Bit Applications to True.

Then try run the site again.
0
 
magicdlfCommented:
"ReportViewer Control 8.0 is part of VS.NET 2008 BUT it is not part of standard .NET Framework.  If you get this error, the hosting server probably doesn't have Report Viewer installed."
http://forums.asp.net/p/1468032/3393255.aspx
0
Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
SM17CHAuthor Commented:
Ive enabled 32bit applications - still no go.
Ive read the thread about ReportViewer already. I dont think thats it as the application doesnt use the reportviewer as far as Im aware. Im trying to track it down anyway.
I think I need to install this - http://www.microsoft.com/downloads/thankyou.aspx?familyId=f5539a90-dc41-4792-8ef8-f4de62ff1e81&displayLang=en&oRef=http%3a%2f%2fmsdn.microsoft.com%2foffice%2fdefault.aspx%3fpull%3d%2flibrary%2fen-us%2fodc_vsto2005_ta%2fhtml%2fOfficeVSTOWindowsInstallerOverview.asp
However it doesnt run on my 64bit system. I cant find an alternative.
Any other ideas guys?
0
 
magicdlfCommented:
"Currently, Visual Studio Setup does not provide bootstrapper support for the 64-bit version of the .NET Framework.
When you build a Setup project that includes the .NET Framework as a prerequisite, the 32-bit version is used. The Setup package does not run on a 64-bit computer because the 32-bit version cannot run under the Windows on Windows (WOW64) subsystem. To work around this issue, you must install the 64-bit version of the .NET Framework manually before running Setup. "
http://social.msdn.microsoft.com/Forums/en/vsto/thread/def2cce2-00b5-48ce-9d18-b0007625cd77
0
 
SM17CHAuthor Commented:
So thats basically saying that I need to install .net framework myself?
Ive already done that as well. The application Im instaling doesnt have a setup program. Rather I am copying the site files from IIS on an old server onto the new server manually.
or have I completly misunderstood what you mean?
0
 
magicdlfCommented:
In that thread, http://social.msdn.microsoft.com/Forums/en/vsto/thread/def2cce2-00b5-48ce-9d18-b0007625cd77, Tim Li suggested go throughthe "Adapting the Setup Project for Windows Vista" part of below article:
http://msdn.microsoft.com/en-us/library/bb332051.aspx#officevstowindowsinstalleroverview_WindowsVista
And you will need to make sure you installed the 64-bit (important) version of .net framework manually before running the setup as he mentioned.
Hope this can help.

0
 
zadeveloperCommented:
Remove the assemblies from the web.config that u are not using
0
 
williamcampbellCommented:
Did you try running VSTOR.exe from the installation CD.?
0
 
SM17CHAuthor Commented:
Hey everyone,
I solved the problem by running a vstore installation that I found on the old server. I dont know where it came from originally. It must have been pt there by the original developers.
thanks for all the help, it pointed me in the right direction.
Cheers

0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 4
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now