• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2492
  • Last Modified:

sybase RSsystem down in replication

Hi,
I got below msgs when issue a replication command who is_down, I tried to resume but it was said not suspended, what is the real issues here ?

1> admin who_is_down
2>
 Spid Name       State                Info
 ---- ---------- -------------------- ----------------------------------------
      DIST       Down                 102 PT1002sql.RSsystem
      SQT        Down                 102:1  DIST PT1002sql.RSsystem
      SQM        Down                 102:1 PT1002sql.RSsystem
      REP AGENT  Down                 PT1002sql.RSsystem
1> resume connection to PT1002sql.RSsystem skip transaction
2>
Msg 15164, Level 12, State 0:
Server 'PT1001sql':
Connection  to 'PT1002sql.RSsystem' is not suspended.
0
motioneye
Asked:
motioneye
  • 3
  • 3
4 Solutions
 
Deepak_FILCommented:
Bring up the replication agent and then re-start the rep server.
0
 
motioneyeAuthor Commented:
hmmm
How to bring up teh replication agent > which replication agent I need to bring up? is there any step I can follow ?
0
 
Deepak_FILCommented:
on your primary ASE (not rep server) check which all rep agents are running :
>sp_help_rep_agent null,process
>go

This will show u, which all rep agents are running for which database. Rep agent threads are on ASE and not on REP SERVER

to start a rep agent do :

>sp_start_rep_agent database_name
>go

Now login to rep server:
>shutdown
>go

then start your repserver again:

./startserver -f ___repserverconfigfile___

(if you dont know how to bring down repserver and how to start it then take some DBA help in ur firm, if its a test server then you can try but dont play with ur business server)
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
motioneyeAuthor Commented:
Hi,
I'm not going to shutdown the replication server, but I will try to sort this with sybase support, btw why we need to issue shutdown on repserver? any ideas? I try with start up the rep agent only, after few seconds it stopped and log showing me below errors:

I. 2010/01/05 07:25:24. Replication Agent for ***.RSsystem connected in passthru mode.
E. 2010/01/05 07:25:24. ERROR #14023 REP AGENT(***.RSsystem) - /execint.c(3461)
        SQM had an error writing to the inbound-queue.
0
 
Deepak_FILCommented:
The above mentioned error comes when: stable device partition is failed (or not available).

looks like u need to rebuild queues but do check with sybase tech support. There may be a loss of data after this.
0
 
jlsilva01Commented:
motioneye,

Try to execute this commands and send the repserver errorlog (file.err) to us (final part):

repserver:
resume distributor PT1002sql.RSsystem
go
resume connection to PT1002sql.RSsystem
go

ase server:
sp_stop_rep_agent <db_name>
go
sp_start_rep_agent <db_name>
go

0
 
motioneyeAuthor Commented:
Hi,
The case resolved, eventually start the RepServ did the job.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now