?
Solved

slow isp connection

Posted on 2010-01-04
3
Medium Priority
?
685 Views
Last Modified: 2013-12-24
I've tried everything to fix this issue. When I connect my PC directly to my cable-modem, my comcast.net connection is great. However when I connect my Linksys 4-port wireless router streaming is horrible.

So I've connected my Cisco 1720 router with a Cisco 3550 switch w/emi and continue to have poor through put.

Attached is the cable modem to C1720 Ethernet 0 interface info from my 'show int e0'. Also attached is my running configuration.

H E L P !!!

Ethernet0 is up, line protocol is up
  Hardware is PQUICC Ethernet, address is 0004.dc0c.ebb4 (bia 0004.dc0c.ebb4)
  Internet address is 76.31.89.121/20
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 10BaseT
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:06, output hang never
  Last clearing of "show interface" counters never
  Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 66000 bits/sec, 18 packets/sec
  5 minute output rate 7000 bits/sec, 2 packets/sec
     460291 packets input, 159511015 bytes, 0 no buffer
     Received 324919 broadcasts, 0 runts, 2 giants, 0 throttles
     785 input errors, 382 CRC, 400 frame, 1 overrun, 0 ignored
     0 input packets with dribble condition detected
     124733 packets output, 17649562 bytes, 0 underruns
     0 output errors, 1579 collisions, 3 interface resets
     0 babbles, 0 late collision, 7477 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Router#
----------------------

Current configuration : 963 bytes
!
! Last configuration change at 22:46:40 UTC Fri Jan 1 2010
! NVRAM config last updated at 22:46:42 UTC Fri Jan 1 2010
!
version 12.2
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
logging queue-limit 100
!
memory-size iomem 25
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.100
!
ip dhcp pool WORKGROUP
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
!
!
!
!
!
interface Ethernet0
 ip address dhcp
 ip nat outside
 full-duplex
!
interface FastEthernet0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 speed auto
!
interface Serial0
 no ip address
 shutdown
!
ip nat inside source list 101 interface Ethernet0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
ip http server
!
!
!
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
!
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end
0
Comment
Question by:mike_n_houstons
3 Comments
 
LVL 1

Assisted Solution

by:kaciuba
kaciuba earned 500 total points
ID: 26178044
Your config looks good.

Here is what I am concerned about.

785 input errors, 382 CRC, 400 frame, 1 overrun, 1579 collisions, 3 interface resets

Im assuming you dont have a multitap or some crazy configuration. If so, you shouldn't have any collissions. To start lets check your cabling for possible sources of interference or noise. If you have ethernet running close to big speakers or fluoro lights in the ceiling thats a killer.

If you think your environment looks ok, clear those interface counters and stream for a few minutes. Let us know what you get.
0
 

Assisted Solution

by:Silverspoon99
Silverspoon99 earned 500 total points
ID: 26178097
Just as kaciuba says- your performance problem is definitely related to the high number of errors you are reporting if these are recent numbers. I have interfaces that have run for years with 0's in all those stats.

Besides checking your cabling, disconnect ALL other network connections except your computer and see if that resolves anything. If not, remove your computer and try a different one in isolation. ?If you find the problem moves, then you may have an incorrectly configured ethernet interface or perhaps a duplicate IP address or even a MAC address collision (some cheap cloned interfaces do not use registered mac addresses which can lead to low-layer collisions).

Basically, clear your stats, run things for awhile and recheck your stats. If the stats show these same high error rates, then set things up in isolation and chack again. When you find the culprit device you can drill down to root cause.
0
 

Accepted Solution

by:
mike_n_houstons earned 0 total points
ID: 26179841
Thanks, I'll try these options when I get in from work later on this evening.
0

Featured Post

Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Originally, this post was published on Monitis Blog, you can check it here . It goes without saying that technology has transformed society and the very nature of how we live, work, and communicate in ways that would’ve been incomprehensible 5 ye…
Tech spooks aren't just for those who are tech savvy, it also happens to those of us running a business. Check out the top tech spooks for business owners.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …

621 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question