Oracle OMS service is not starting

Hi Experts,

Currently i am facing oracle issue. the details are given below.

I am not able to start OracleOraHome92ManagementServer service in control pannel. it was giving error (please find the attached image). The application event and system event are given below

Application event:-

Event:1000
Faulting application TNSLSNR.EXE, version 0.0.0.0, faulting module orantcp9.dll, version 0.0.0.0, fault address 0x00005732.
Event :113
OracleOraHome92ManagementServer
The process termination failed for JRE.  %2.
Event : 112
OracleOraHome92ManagementServer
The service has terminated abnormally.  See the file C:\oracle\ora92\sysman\log\oms.nohup for details.

System event :-

Event 7031
Service Control Manager
he OracleOraHome92ClientCache service terminated unexpectedly.  It has done this 1 time(s).  The following corrective action will be taken in 60000 milliseconds: Restart the service.

Kindly guide us on this issue.

i have run the below steps, but no solution

1) Run "netsh winsock reset catlog" as there was event id 1000 was generating and restart the server but we are not able to start the service.
2) Run the WinsockFix but were failed.

Please find the oms.nohup error log file.
New-Image.JPG
oms-noup.txt
srinivas_ganamurAsked:
Who is Participating?
 
schwertnerCommented:
Most common reasons:
1. Change of the IP of the computer
2. Change of the domain name
3. Change in the network - default gateway, DNS address
4. Not working network cable or NIC (network card)
5. Service that needed to be started before this service is not started.
6. The user that starts the service is not the administrator

This is the order

REM "dbstart.cmd"
@echo off
set ORAHOME="OraHome92"
set ORASID="ORCL"
net start OracleService%ORASID%
REM net start Oracle%ORAHOME%HTTPServer
REM net start Oracle%ORAHOME%TNSListener
REM net start Oracle%ORAHOME%ClientCache
REM net start Oracle%ORAHOME%Agent
REM net start Oracle%ORAHOME%SNMPPeerEncapsulator
REM net start Oracle%ORAHOME%SNMPPeerMasterAgent
REM net start Oracle%ORAHOME%PagingServer
REM net start OracleMTSRecoverService

0
 
schwertnerCommented:
9.2.0.1 is extremely bugy.
Oracle didn't support versions before 9.2.0.4

I will suggest first to migrate to higher version and to
give a try after that.
0
 
srinivas_ganamurAuthor Commented:
but before this service is working fine i mean before i am able to start and stop this service. but now this service is not starting.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
srinivas_ganamurAuthor Commented:
what could be the reason and what is the solution?
0
 
srinivas_ganamurAuthor Commented:
Good Morning Schewertner,

Today please clarify below Questions:

Question 1:
As per your suggestion, i have run the above commands in CMD..all services are started except OracleMTSRecoverService (service not found error).

when i executed oemctl status oms....i have given password and username and i got the below error msg in cmd.

error msg:
Unable to bind to oms server XYZ.

Question 2:

Is it possible to drop existing OMS database (OEMREP database name) and create new OMS database. is there any impact on user database? i think the password what i have given to OMS is not correct.
0
 
srinivas_ganamurAuthor Commented:
i dont the oms database password.....i have opened in Ent manager console....there i have given username and password (for connecting oemerp database)...it was not connecting that is it was showing message "connecting to repository......" it was taking long time
0
 
srinivas_ganamurAuthor Commented:
or it is better to reinstall fresh OMS service????
0
 
schwertnerCommented:
Please investigate if you have running firewalls/antiviruses on the computer.


Question 1:
Do also this
export ORACLE_SID=XYZ

Question 2:

Only dropping and recreating is not a way. There a special schemas and tables .....
Is it running? Is the listener running?
Possibly there is an agent that should also run
 
0
 
schwertnerCommented:
Also going to a DOS/Command prompt and issue the command:

OEMCTL START OMS

You should get the Oracle error that is being reported. Also, check the files located in the $ORACLE_HOME\sysman\log directory. You should see something like oms.nohup there -- this file can be rather large at times, so I might suggest renaming the file, then execute the OEMCTL command above.... it will re-create the .nohup file.

This is from
http://www.dbforums.com/oracle/1002374-oracle-management-server.html
0
 
srinivas_ganamurAuthor Commented:
No use from your given link.......

1. After execution of OEMCTL START OMS
Output:The OracleOraHome92ManagementServer service is starting.......
The OracleOraHome92ManagementServer service could not be started.

0
 
srinivas_ganamurAuthor Commented:
Question 1:
Do also this
export ORACLE_SID=XYZ

please explain me what it will do and how to use this in CMD/SQL plus?
0
 
schwertnerCommented:
Reinstallation possibly will help.
But be aware that installation of every other product after
installation can damage the previous installation.
Have you installed other product recently on the server?
0
 
srinivas_ganamurAuthor Commented:
please let me know the path of omsconfig file (oracle 9i)...User databse tns listner service is running properly...
0
 
srinivas_ganamurAuthor Commented:
no i have not installed any other products on server? My collegue is suggesting me....take backup of user database (only one DB) and uninstall Oracle 9i (remove registery). Start fresh installation (same version) after installation restore backup....any suggestions from your side?

Version: Oracle 9i
Frint end: java



0
 
srinivas_ganamurAuthor Commented:
this is all coz of only OMS service.............
0
 
schwertnerCommented:
Try to connect the DB using SQL*Plus
If you succeed why will you reinstall the DB?
It should working...
0
 
srinivas_ganamurAuthor Commented:
u mean user DB or OEMREP DB (OMS database)???




0
 
schwertnerCommented:
Both!
If both are running and accessable why to drop them?
0
 
srinivas_ganamurAuthor Commented:
Yes..i am able to connect both dbs.....but one more thing when i starred all oracle services iam getting error mesage (please see the attached image)..what could be the reson
0
 
schwertnerCommented:
Are the both DBs on one computer?
If yes - then they should use only ONE common listener.
If there are 2 listeners that use same port then this will cause
troubles. use the Listener with the higher version.
0
 
srinivas_ganamurAuthor Commented:
what is the default path of OMS listener? i knw the default path of user DB....please give me path of (default) oms listner?....so i'l compare two listeners
0
 
schwertnerCommented:
Only the DB have listeners.
If OMS it should have config files in OMS_HOME\network\admin
0
 
srinivas_ganamurAuthor Commented:
--
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.