[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2115
  • Last Modified:

OWA not working - page cannot be displayed

OWA is not working on our new Exchange 2003 server (it was until about 8am this morning).

If I go to http://localhost/exchange from the server I get page cannot be displayed, same as I get if I try to access OWA externally. There are no errors in Event Viewer.

I know there is a good MS kb on OWA permissions I am going to try to find that now but if anyone has any ideas please let me know...
0
ob1_
Asked:
ob1_
  • 10
  • 7
  • 7
  • +1
3 Solutions
 
tusharnextgenCommented:
please check if iis services are running, please try to run iisreset and check after that from exchange server
0
 
ob1_Author Commented:
All Exchange services are running. I did the IISRESET but this did not fix the issue.
When I go into ESM and look at Status I get a notification for Critical for my server, even though all services are running. Not sure if this has anything to do with it.
0
 
Narayan_singhCommented:
These are the permissions you can check in IIS:

1) Default Website : Annonymous & Integrated     NO SSL
2) Exadmin : Integrated                                    NO SSL
3) Exchweb : Annonymous                              NO SSL
4) Exchange: Basic                                        SSL Optional
5) RPC     : Basic                                        SSL Required
6) OMA     : Basic                                       SSL Optional
7) Public  : Basic+Integrated                         SSL Optional
8) exchange-oma : Basic & Integrated             NO SSL
9) Microsoft-Server-ActiveSync : Basic           SSL Optional


if it doesnt work reset the virtual directories by following method 2 of KB 883380
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
Glen KnightCommented:
first thing to do is reset the virtual directories as per: http://support.microsoft.com/kb/883380
I use method 2 but others use method 3.

0
 
ob1_Author Commented:
I checked permissions per Narayan's post and made the changes below, did an iisreset and this did not fix the issue. Although - I do not have an "exchange-oma" website. Is this an issue? I am going to try method 2 from the KB now.
added integrated to default website
removed integrated from exchange website
removed anon and integrated from RPC - added basic + ssl  
thanks,
Bobby
 
 
0
 
Narayan_singhCommented:
Exchange-oma is not created by default it is just for ActiveSync when you have FBA enabled so no need to wory about it.... not related to OWA at all.follow the method 2 of Kb 883380 and see if it works
0
 
ob1_Author Commented:
Ok - i followed method 2 of the kb all the way through and the issue still persists. what should i try next?
0
 
Glen KnightCommented:
Can you get OWA from your exchange server if on the exchange server you browse to http://localhost/exchange ?

If not what error do you get?
0
 
Narayan_singhCommented:
What about just browsing just default website open IIS and right click on default website or open IE and just type localhost
see if you get the IIS page Under construction.
0
 
ob1_Author Commented:
I tried http://localhost and http://localhost/exchange and both come up as "The page cannot be displayed".
"The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings. "
0
 
tusharnextgenCommented:
open IIS manager goto exchange directory right click and say browse
please let us know what error message it gives
0
 
ob1_Author Commented:
Same - The page cannot be displayed
0
 
tusharnextgenCommented:
is it asked you for credential. and after providing credential it has given "page cannot be displayed"
0
 
Glen KnightCommented:
I would remove and reinstall IIS as per: http://support.microsoft.com/kb/320202

make sure you follow the steps exactly.
0
 
tusharnextgenCommented:
do we have any logging enable please check Httperr.log.
0
 
tusharnextgenCommented:
please be aware reinstalling IIS would break exchange and you have to reinstall exchange after you reinstall IIS
0
 
ob1_Author Commented:
it does not ask for my credentials. well that sucks - i guess there is no way to fix it without taking down Exchange at this point??
0
 
tusharnextgenCommented:
But its sounds logical to reinstall IIS and then exchange as suggested by our friend demazter
0
 
tusharnextgenCommented:
although this link may not be necessarily related to our issue I am not sure because we dont have httperr.log
http://support.microsoft.com/kb/934878
0
 
Glen KnightCommented:
The document improvised a link for explains how to remove IIS from a server that is running Exchange, that's why I posted that link!!

Maybe you should read it before knocking it?
0
 
Glen KnightCommented:
My previous comment was not aimed at you author!
0
 
ob1_Author Commented:
No problem - I appreciate all the comments. While waiting until tonight when I can re-install IIS I am looking at the other posted KB: http://support.microsoft.com/kb/934878.
I actually do have the /3gb switch in the boot.ini and the connections refused errors in the HTTPERR log described in the KB.
I added the aggressivememory key to the registry and restarted IIS. OWA is now working internally - if I go to IIS Admin I can browse to the site and login.
It is not working externally or from PDA's - could this be a permissions issue?
 
Thanks,
Bobby
0
 
Glen KnightCommented:
That's excellent, if it's working then there is no need to reinstall IIS.

Just check that port 443 is still being forwarded to the exchange servers IP address.

Can you goto: https://www.testexchangeconnectivity.com/ and test the connectivity to your server.
0
 
ob1_Author Commented:
I took screenshots of the results and have attached them...
 
 

test-pg1.jpg
test-pg2.jpg
0
 
Glen KnightCommented:
Can you try these trouble shooting steps: http://support.microsoft.com/kb/330463
0
 
ob1_Author Commented:
I had to add Integrated authentication back to the Exchange website per the suggestion on the connectivity test website and now the issue is completely resolved.
Thanks everyone for your help I really appreciate it !!!!!!!!!!!!!!!!!!!!!!!!!
0
 
ob1_Author Commented:
Thanks!
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 10
  • 7
  • 7
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now