Problems Installing Windows XP SP3 - Receiving Access Denied

In reading through posts on the web I found a fix that was published for the "Access Denied Error" received when trying to install SP3.  However, this fix didn't correct the problem for us.

Below is what we have tried:  "We get an Access Denied when we run the patch.  We found some information with regard to the error and it says to run the subinacl.msi and then run the following registry settings:

cd /d "%ProgramFiles%\Windows Resource Kits\Tools"
subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
subinacl /subdirectories %windir%\*.* /grant=administrators=f /grant=system=f
secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose   "

The tool installs fine but we are getting errors on the first line for the HKLM.  I havent been able to see both errors but one of the keys is

                HKLM\Security\Policy\Secrets\SAI

From what Ive read the other is probably

HKLM\Security\Policy\Secrets\SAC

And even with Administrators having full control over the HKLM\Security folder we still dont have rights to even look at the SAI or SAC keys.  The stuff Im finding on line describes the problem, but I havent found any resolutions yet.  I need to upgrade approximately 4,000 workstations.

Has anyone run into this at all?  Any guidance would be most appreciated!!!

Thanks,
Carol
cdarney1Asked:
Who is Participating?
 
cdarney1Author Commented:
The resolution to our problem was permissions on a registry key.  Provided full permissions to the "administrators" and system accounts on the HKLM\Software\Microsoft\Windows NT\CurrentVersion\Svchost\ key ) solved the issue.

Thanks for your help.
0
 
jaynirCommented:
Here's a couple of things i would try.

1. Start>Run> sfc /scannow (Insert windows XP cd)
2. Start>Control Panel>Add/Remove programs> Uninstall previous service packs
3. If that doesn't help, restore it to previous restore point.

after it restores, then install service pack again.
0
 
flubbsterCommented:
Download and install Dial-a-fix:

http://wiki.lunarsoft.net/wiki/Dial-a-fix

Click on Tools, then select Rest Permissions, and click "Go"

Try installing sp3 after
0
 
cdarney1Author Commented:
Thank you for the responses, but unfortunately I'm installing on approximately 4,000 workstations so these solutions are not feasible.  Does anyone else have any suggestions?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.