• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 656
  • Last Modified:

Going bald over a Cisco ASA 5505

I'm rapidly loosing my hair over what should be a simple ASA 5505 configuration.  I can't get smtp (port 25) traffic from the Internet to pass through the firewall to the inside host. The inside servers and workstations can access the Internet just fine but nothing from the outside can come in even through I think I've configured the access rules and NAT rules properly. Any help would be greatly appreciated.  Below is the sh config output:
!
ASA Version 8.2(1)
!
hostname xxxASA
domain-name xxx.xxx.xxx
enable password ................... encrypted
passwd ................. encrypted
names
name 192.168.2.10 COPSrv01 description COP SBS Server
name 192.168.2.11 COPTrm01 description COP Terminal Server
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.2.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address xx.xx.xx.xx 255.255.255.224
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone PST -8
clock summer-time PDT recurring
dns server-group DefaultDNS
 domain-name xxx.xxx.xxx
access-list inbound extended permit tcp any any eq 3389
access-list inbound extended permit tcp any any eq ssh
access-list inbound extended permit tcp any any eq smtp
access-list inbound extended permit tcp any any eq https
access-list inbound extended permit tcp any any eq www
access-list inbound extended permit icmp any any
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-621.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 3389 COPTrm01 3389 netmask 255.255.255.255
static (inside,outside) tcp interface ssh COPSrv01 www netmask 255.255.255.255
static (inside,outside) tcp interface smtp COPSrv01 smtp netmask 255.255.255.255
static (inside,outside) tcp interface https COPSrv01 https netmask 255.255.255.255
access-group inbound in interface outside
route outside 0.0.0.0 0.0.0.0 68.179.192.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.2.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.2.5-192.168.2.36 inside
!

threat-detection basic-threat
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
webvpn

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:39d60d79398bb0dc3a88d8270d037f70
0
jimsqu
Asked:
jimsqu
  • 4
  • 3
  • 2
2 Solutions
 
Jody LemoineNetwork ArchitectCommented:
The firewall configuration looks good.  Is your SMTP server's default router pointed to 192.168.2.1?  Are you able to telnet to port 25/tcp on 192.168.2.10 from the LAN?  Lastly, is the SBS firewall active on COPSrv01?
0
 
jimsquAuthor Commented:
I don't quite understand your question about the smtp server's default router being pointed to 192.168.2.1?

I am able to telnet to port 25/tcp on 192.168.2.10 from within the LAN

The SBS firewall is turned off.

When I try to telnet from the outside to port 25/tcp on the outside interface I get these messages in the log:6      Jan 05 2010      09:46:41      302013      68.179.222.66      55546      COPSrv01      25      Built inbound TCP connection 1872 for outside:68.179.222.66/55546 (68.179.222.66/55546) to inside:COPSrv01/25 (68.179.192.2/25)
6      Jan 05 2010      09:47:11      302014      68.179.222.66      55546      COPSrv01      25      Teardown TCP connection 1872 for outside:68.179.222.66/55546 to inside:COPSrv01/25 duration 0:00:30 bytes 0 SYN Timeout

Thanks for your help
0
 
Jody LemoineNetwork ArchitectCommented:
It looks like the COPSrv01 server isn't responding to the inbound request.  What do you get when you run an "ipconfig" command on COPSrv01?
0
Become a Leader in Data Analytics

Gain the power to turn raw data into better business decisions and outcomes in your industry. Transform your career future by earning your MS in Data Analytics. WGU’s MSDA program curriculum features IT certifications from Oracle and SAS.  

 
Istvan KalmarCommented:
try it:

policy-map global_policy
 inspect esmtp
0
 
jimsquAuthor Commented:
Turns out it was a stupid Micro$oft thing.  They don't, (in windows 2003) properly support multiple default gateways.  I had the server configured so that it should have responded to the default GW for the same subnet but it wasn't doing it.  The responces were always going to the same default GW which was in the wrong subnet.

The fix was to completely disable the (old) primary IP address and GW and only use the new ones that were behind the Firewall. Then things worked like they should.
0
 
Jody LemoineNetwork ArchitectCommented:
So the problem *was* that the COPSrv01 server wasn't responding to the inbound request.  This due to its not using the correct default router, which would have been revealed by the "ipconfig" command as I suggested.
0
 
Istvan KalmarCommented:
did you tried fixup on ASA?
0
 
Jody LemoineNetwork ArchitectCommented:
The problem was solved by the author by investigating the server configuration as suggested by "It looks like the COPSrv01 server isn't responding to the inbound request.  What do you get when you run an "ipconfig" command on COPSrv01?"  I recommend that this solution be accepted.
0
 
Istvan KalmarCommented:
did you tried fixup on ASA?
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

  • 4
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now