[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 870
  • Last Modified:

Adminstrators denied access in Windows 7. How to get access back?

A deny permission was assigned on the root directory by right clicking on C:\ then using security tab. The deny permission was set on Authenticated Users and One Guest User.

The objective was to deny all access from this Guest User to all files and folders. However the result was deny of access to all users including administrators.

To fix this I've booted the computer in Safemode with command prompt and managed to enable the default administrator account named "Administrator". Which is inactive by default. But this account doesn't have access to the root directory either.

My system is a dual operating system. With Windows XP and Windows 7 (Release Candidate version). When I log boot with Windows XP the partition on Windows 7 is not accessible.

How can I get back access to my files under the Windows 7 partition? Will reinstalling Windows 7 solve this problem?
0
happyCoder
Asked:
happyCoder
  • 5
  • 2
  • 2
4 Solutions
 
Ignition_HelpdeskCommented:
bring up the security settings for the folder, edit, go into Advanced, and set Ownership back to Administrator. Choose to apply to all sub folders. Once you do that, edit the permissions again and give the Administrator Full Control on the folder and all subfolders.

You can also try a system restore if you have backups

If that doesn't work, a repair, or reinstall will.
0
 
NikCommented:
Taking ownership of the folder/files is the only solution and will surely work if you're using Administrator account. You won't need to reinstall your system.
0
 
happyCoderAuthor Commented:
When I login the only areas I can access are the desktop and public users folder. If I right click on c:\ and select properties the Security Tab does not appear. I tried using My computer>Manage and I see the list of users and groups but attempting to change the privileges result in access denied.

Also when I try to access c:\ in windows explorer access is denied. When I do start>run and type a path such as c:\windows , access is still denied.

I tried to take ownership by using Command line using takeown and icacls commands. But after taking ownership, access is still denied. So I assumed the reason could be becauset the deny was applied to Authenticated Users group and administrator is a part of that group. So deny takes priority and access is denied. I tried taking administrator off the Authenticated groups but I couldn't figure it out. Then I created a new user (assuming the user will not be automatically part of Authenticated Users). I logged in to Windows using this new user. But this new user is still denied access.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
NikCommented:
When you took ownership of the C:\drive, you should have the security tab now, don't you?
0
 
Ignition_HelpdeskCommented:
taking ownership is not the same as getting permission to view the folders. Think of taking ownership as forcing the computer to give you the right to adjust permission. You're not forcing the computer to give you full access, just forcing the computer to give you the ability to give yourself full access if you want it.

Once you take ownership you have to then adjust the permissions. Taking ownership doesn't automatically give you access, you have to edit the security permissions again after you take ownership of a folder. Give it another shot. IF, after you give yourself ownership, you cannot adjust the permissions you're going to need to re-pair or re-install the OS
0
 
happyCoderAuthor Commented:
I'm at work now and this is happening on my home pc. I'll get home around 5:30PM CST and I will be able to check that and give you feedback by then.

Thank you for helping me with this.
0
 
happyCoderAuthor Commented:
I must have made a mistake when using takeown. It doesn't look like the administrator has owenership on C:\. When I boot windows normally and login with administrator the security tab doesn't show in root directory properties. When I boot in safe mode with command prompt, and then start explorer.exe and look at c:\ drive properties, I was able to see the security tab and then Owner tab.

In the current Owner information box, it says cannot show current owner. And in the list below it shows Administrator and Administrators Group. When I click Edit I got an error saying "Can't open access control editor. Access is denied"

here is a picture someone posted:
http://www.al3assi.org/up/uploads/images/al3assi.com-fefbf7a083.png

And here is a link to a forum with similar problem. I plan on trying the suggested steps tonight.
http://social.answers.microsoft.com/Forums/en-US/w7security/thread/0b938de0-620c-417f-a2b6-50a9c7f58766

Thanks
0
 
happyCoderAuthor Commented:
When I tried to use takeown in command prompt and command prompt in safemode, it fails with Access is denied.
0
 
happyCoderAuthor Commented:

I disabled the User Access Control from registry then booted in safemode and was able to take ownership by right clicking C:\ drive, then properties and using Security tab. Then I was able to change privilege on Authenticated users and Users from deny to allow full control. Then I rebooted windows normally and was able to access my folders by loginning using an administrator account.

To disable User Access Control I followed these steps:

Method 3  Using Registry Editor

   1. Run Registry Editor by typing regedit in Start Search or command prompt.
   2. In Registry Editor, navigate to the following registry key:

      HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
      CurrentVersion\Policies\System
   3. Locate the following DWORD registry subkey in the right pane:

      EnableLUA
   4. Right click and choose modify or double click on EnableLUA to modify the setting. On valud prompt, set the new value to 0.
   5. Exit from Registry Editor.
   6. Restart the computer.

source: http://www.mydigitallife.info/2006/12/19/turn-off-or-disable-user-account-control-uac-in-windows-vista/
page title: Turn Off or Disable User Account Control (UAC) in Windows Vista
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

  • 5
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now