[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 435
  • Last Modified:

SMTP 503 Error on Verizon

I have a couple of users who keep getting a 503 valid RCPT command must proceed data error in outlook. After checking all settings, deleting and recreating the account, deleting the profile, and reinstalling office to try and fix the problem. I came to find out that the error only happens when they are connected to the internet through Verizon or Armstrong Cable. If they connect through SBC, Cox, Qwest and any other ISP they can send emails with no problem.

The SMTP server is using port 587 and they can telnet into the SMTP server on this port. So it's not a case of the ISP blocking those ports.

After searching here and anywhere else i can think of all i could find was to make sure outlook was authenticating. But because we know the settings are correct and that the same account works on other networks that isn't the issue here.

The funny part is that the users in question use IMAP and when they get the send error it goes into the personal folders inbox instead of the users email account inbox.
0
droeder
Asked:
droeder
  • 6
  • 6
1 Solution
 
Alan HardistyCommented:
Does the mail provider that you use not allow you to use their SMTP server using authentication so that you don't have to keep switching outbound servers, which I would imagine is a huge pain in the ass?!
Any reason for using IMAP?  Is that all the mail provider can offer?
There are alternative solutions that would stop this error happening in the first place such as HTTP over RPC (or Outlook Anywhere).
0
 
droederAuthor Commented:
We are hosting our own server here and authentication is turned on. They are not switching outbound servers i was talking about which ISP they were connected to for internet access not SMTP servers.

The user in question is using IMAP because he access's email on his blackberry/laptop/and through webmail and needs full access to all emails on all 3. But since the issue is with SMTP and it shouldn't matter whether he is using IMAP or POP3.

I haven't tried anything like those since the issue is limited to when they are connected to Verizon or Armstrong Cable.
0
 
Alan HardistyCommented:
Ah - okay - my mistake.  I thought they might be having to switch mail servers.  Not to worry.
Are you an Exchange house or an alternative product?
Essentially what is happening is that the order of the SMTP commands is being altered and I can only imagine that this is something on the Verizon or Armstrong routers.
If you are an Exchange house, then you can do away with IMAP and use HTTP over RPC, but if not, then I think you will need to contact the ISP's and ask them.
Have you disabled / uninstalled any Anti-Virus software on the problem computers as this can often cause problems (although maybe not ISP specific randomness!)?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
droederAuthor Commented:
We are using an alternative product with Dovetail and Exim.

I tried disabling the anti-virus but that does nothing to help fix it.
0
 
Alan HardistyCommented:
Okay - not to worry.
It is often worth uninstalling Anti-Virus software and then testing as disabling can often be a complete waste of time!
Have you run Detect & Repair for Office to see if that resolves any issues and also patched it with the latest Service Pack?
0
 
droederAuthor Commented:
The computers are not in the office here and the anti-virus software doesn't like being messed with remotely. So i haven't tried uninstalling it, however we have made sure that Office was fully up to date and rand the Detect and Repair on it.
0
 
Alan HardistyCommented:
So just to confirm, this happens on multiple computers to multiple users and only when on certain ISPs?

Do you have a test laptop that you can remove Anti-Virus software from and test on the relevant ISPs?
0
 
droederAuthor Commented:
We have 3 users who have this issue. One is using Armstrong Cable, but can hop on Verizon with a data card and has issues on both. Another uses Verizon and has the issue, and the last has Cox and works with no issues however when traveling he sometimes uses a verizon data card and has this issue when he uses it.

I have a verizon data card i can test the issue on when needed.
0
 
Alan HardistyCommented:
I think we can pretty much rule out your hardware and software and lay the blame squarely at the feet of the ISP.
0
 
droederAuthor Commented:
After talking with the ISP verizon i get the feeling they only allow SSL connections on those ports. After i get  SSL up and running i will let people know for sure if that is the fix.
0
 
Alan HardistyCommented:
Well that sounds promising. Please us posted and good luck.

Alan
0
 
droederAuthor Commented:
After getting SSL working that took care of the problem. So it appears that verizon only allows SSL connections on ports 587 and 2501. So if you try to do smtp without SSL on those ports it will give you a 503 error.
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

  • 6
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now