SQL Server question

Hello

I have installed SQL Server 2008 on 2 PC's. On one, i can connect using "localhost", on the other I can only connect using "MyPCNAME\local"

How can I change that, so I can also connect using localhost?

Thanks
RuttensoftAsked:
Who is Participating?
 
beesterConnect With a Mentor Commented:
You have to install SQL server with the choice of DEFAULT INSTANCE under the installation instead of named instance. This can be done by selecting advanced setting during the installation.

SQL Server Express defaults to a named instance called computername\SQLEXPRESS.

Regarding the reinstallation problem:

Try this:

Open Regedit
Find the key "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager"
Rename the "PendingFileRenameOperations" value to "PendingFileRenameOperations2"
0
 
chapmandewCommented:
in sql configuration manager, do you have tcp/ip network protocols enabled?

are you trying to connect to these instances on the physical machine?
0
 
Chris LuttrellSenior Database ArchitectCommented:
localhost is just an alias pointing to your machine by name, in effect using MyPCNAME in your example.  Is it possible that you have more than one instance of SQL on the second machine, in which case it would have required you to "Name" the second instance and you can only refer to it with a MachineName\InstanceName?
There are several things that could be wrong, and without the complete configuration or access it is hard to diagnose.
0
 
RuttensoftAuthor Commented:
Hi

Actually I didnt know that I had 2 instances - that seems to be the problem. I have now uninstalled everything, but now I cannot reinstall SQL .... arggggh. Setup passes all tests, installs the Setup Support Files and after that, it just is closing :(

No error message, nothing :-(
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.