• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 866
  • Last Modified:

McAfee internet access problems

I manage a small network (100pcs).  I recently deployed Mcafee Total Protection.  On some it works fine and on some I have no internet access.  I have uninstalled the McAfee suite from one of the PCs (running Windows 2000 Pro) and still cannot reconnect to the internet. I have adjusted the network communication to be "Trusted Network", but so far that hasnt helped.
Anyone have an answer?
0
dskemp
Asked:
dskemp
  • 4
  • 3
2 Solutions
 
Mike_CarrollCommented:
Are you getting valid ip addresses and gateways?
0
 
dskempAuthor Commented:
I run ipconfig and appear to get valid IP etc.  I have run ipconfig/release etc. on the PCs.  The IPs come back the same.
0
 
Mike_CarrollCommented:
can you ping localhost or 127.0.0.1 ?
can you ping the gateway ip ?
can you ping an ip on the Internet, for example 216.239.59.147 ?
can you ping a domain name, for example google.com ?
0
The Lifecycle Approach to Managing Security Policy

Managing application connectivity and security policies can be achieved more effectively when following a framework that automates repeatable processes and ensures that the right activities are performed in the right order.

 
dskempAuthor Commented:
I have tried to ping google.com with no luck..I haven't tried the 127... am not seated at the problem right now.  Will try that when I get back to the network.
0
 
dskempAuthor Commented:
I can ping 127.0.0.1 successfully.
I checked the ip, gateway, etc and have the following:
169.254.135.245
subnet was: 255.255.0.0
no Default Gateway.
I went in and manually configured the IP, subnet, and gateway to be consistent with our network, still with no result.
I manually configured the DNS (which was also missing)
When I try to connect to the internet, an error message at the bottom (which appears only momentariily) suggests a dll.? and a DNS error.
I also have uninstalled/reinstalled the network adapter.
Again, this machine was working fine before the McAfee install.
0
 
Mike_CarrollCommented:
The 169. ip address is an auto-config ip which Windows gives itself when it can't contact a dhcp server. Sound slike McAfee is blocking something.

Try to reset the winsock... from a command prompt, type:

 netsh winsock reset

and press ENTER

Do a restart and lets see what happens.
0
 
dskempAuthor Commented:
I had five PCs here that were effected.  Thanks, that did it for four of them...the fifth had a totally unrelated issue, that just looked like the others.....Thank you so much...now i can finish installs on the rest of the network....with confidence that I won't lose the internet....thanks again.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now