• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2041
  • Last Modified:

Unable to ping across VLANS

I'm new to the cisco world so forgive me if this is a silly question but I have a small home lab setup to help start towards my ccna and i have configured a few simple vlans but I am unable to ping host to host across the vlans. for example laptop in VLAN 10 cannot ping laptop in VLAN 20. but both laptops can ping their respective default gateways and the router. i know its probably something simple. thanks for any help/tips/advice!

using router on a stick configuration with a cisco 1751 series router and a 2950 series switch

router config:
Current configuration : 1348 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname jmark_router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$cLLE$LppOj7/V92yYWje9MYsUy/
!
no aaa new-model
memory-size iomem 25
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
ip cef
no ip domain lookup
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 speed auto
 full-duplex
!
interface FastEthernet0/0.1
 description Management VLAN 1 - Native VLAN
 encapsulation dot1Q 1 native
 ip address 172.16.0.1 255.255.255.0
!
interface FastEthernet0/0.10
 description Sales Office VLAN
 encapsulation dot1Q 10
 ip address 172.16.10.1 255.255.255.0
!
interface FastEthernet0/0.20
 description Accounting VLAN
 encapsulation dot1Q 20
 ip address 172.16.20.1 255.255.255.0
!
interface FastEthernet0/0.30
 description Network Operation Center VLAN
 encapsulation dot1Q 30
 ip address 172.16.30.1 255.255.255.0
!
router rip
 version 2
 network 172.16.0.0
 no auto-summary
!
ip forward-protocol nd
no ip http server
!
!
!
control-plane
!

!
line con 0
 password 7 13061E010803
 logging synchronous
 login
line aux 0
 password 7 0822455D0A16
 login
line vty 0 4
 password 7 1511021F0725
 login
!
end



switch config:
Current configuration : 2662 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname jmark_switch
!
enable secret 5 $1$7gxK$sEOxxccizPj2RpEUamfXA/
!
ip subnet-zero
!
no ip domain-lookup
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
 description Trunk Link to jmark_router
 switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/8
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/9
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/10
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/11
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/12
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/13
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/14
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/15
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/16
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/17
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/18
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/19
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/21
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/22
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/23
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/24
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface Vlan1
 ip address 172.16.0.2 255.255.255.0
 no ip route-cache
!
ip default-gateway 172.16.0.1
ip http server

!
line con 0
 password 7 1511021F0725
 logging synchronous
 login
line vty 0 4
 password 7 1511021F0725
 login
line vty 5 15
 login
!
!
end
0
duggy22
Asked:
duggy22
1 Solution
 
kaciubaCommented:
Have you created the vlans on the switch? Do a "show vlan brief" and see if you can see them in the list. If you dont, you will need to go in to config mode and

vlan 10
desc Vlan10

vlan 20
desc Vlan20

vlan 30
desc Vlan30

Also, use a "show int fa 0/1 trunk" to see what vlans are able to run across your trunk.
0
 
duggy22Author Commented:
vlans are already created on the switch

i ran show int fa0/1 trunk and all vlans are allowed on the trunk
0
 
kaciubaCommented:
Enable "ip routing" on the switch
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
duggy22Author Commented:
ah ok it appears that the cisco 2950 series switch does not support ip routing but if it did im sure that would fix the problem lol
0
 
kaciubaCommented:
No you should still be able to get it to work. I think its the "native" you have set on the router VLAN1. Just set it without the native command.
0
 
Istvan KalmarCommented:
HI,

Please use router for routing behind VLANs, and it will be working....

Please configure trunk for router port.... And configure subinterfaces on router:


For example:
on router
int fa0/1
encap dot1q 1 native
ip address 192.168.1.1 255.255.255.0
int fa0/1.2
encap dot1q 2
ip address 192.168.2.1 255.255.255.0
int fa0/1.3
encap dot1q 3
ip address 192.168.3.1 255.255.255.0

on switch:

int fast 0/0
desc to switch
switchport encap dot1q
switchport mode trunk
int fast 0/1
swi acc vlan 2
int fast 0/2
swi acc vlan 3


for more information please refer this page:
http://www.cisco.com/en/US/tech/tk389/tk390/tk6/tsd_technology_support_sub-protocol_home.html


dot1q.JPG
0
 
Vito_CorleoneCommented:
Config looks good to me. Can you post the out put of "sh ip int b" on both devices and "sh vlan" on the switch?
0
 
rochey2009Commented:
can you also post

show int trunk from the switch

and

on the router

show ip int brief
show ip route
0
 
mawueliCommented:
..i am coming back to the very first comment of kaciuba.

in my opinion the vlans are not properly configured in case the config you posted is the running one.

Just to be sure pls do me the favour and - for testing- just do:

"conf t"
"int vlan 10" (and so on with all vlans you need)

...would bet something the switch will come up with a message like " vlan xx does not exist, creating..."
and this might already fix your issue...
0
 
duggy22Author Commented:
I am closing this question so I may open a new question. Scott
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now