[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 9797
  • Last Modified:

Problem requesting Certificate from CA

I just now installed a CA (Certification Authority) on my Windows 2003 test machine. After the install, in which I did not make any changes to the default, I went to http://127.0.0.1/certsrv. Then I logged in as Administrator, clicked on "Request a certificate", then "User Certificate". In the next page, there is a drop-down menu titled "Key Strength", but the list of options is entirely blank. When I click the "Submit >" button, I receive the following error:

--------------------

Error

Your request failed. An error occurred while the server was processing your request.

Contact your administrator for further assistance.

Request Mode:
newreq NN - New Request (keygen)
Disposition:
(never set)
Disposition message:
(none)
Result:
The data is invalid. 0x8007000d (WIN32: 13)
COM Error Info:
CCertRequest::Submit The data is invalid. 0x8007000d (WIN32: 13)
LastStatus:
The operation completed successfully. 0x0 (WIN32: 0)
Suggested Cause:
The certificate request contained bad data. If you are submitting a saved request, make sure that the request contains no garbage data outside the BEGIN and END tags, and that the file containing the saved request is not corrupted.

--------------------

I'm fairly certain the "Key Strength" issue is the problem. Any ideas on how to remedy this issue?
0
pzkhan
Asked:
pzkhan
1 Solution
 
kortinaCommented:
Try each of the following:
Accessing the website from a computer that doesnt have the IE Enhanced Security installed
Add localhost to the trusted sites list.
Uninstall IE Enhanced Security from your CA server.
0
 
pzkhanAuthor Commented:
I do not know what the IE Enhanced Security is, nor how to add localhost to the Trusted Sites list.

I am using Chrome, if that makes a difference. When I try it with IE, I get this error: "This web site requires that scripting be enabled in your browser. Please enable scripting and try your last action again. "
0
 
Patmac951Commented:
In IE find the tools menu (depends on the version) select 'Internet Options', 'Advanced' tab, under 'Browsing' uncheck 'Disable Script Debugging' then try to request the certificate again from IE.  If you are getting a true script error on the page this should give you more details of the problem.
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now