• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1390
  • Last Modified:

Real VNC - Mac to Windows 7 - Blank Screen

I am using:

Enterprise Edition of Real VNC
Mac OSX 10.6
Windows 7

When I connect from my pc to my mac Real VNC works perfectly, however when I try to connect from my mac to my pc it doesn't.  The connection is made and everything seems to have connected fine but on my mac i am greeted with a blank screen.  When i move my mouse it still moves on my pc and if i switch from full screen mode to windowed mode i get a "screenshot" of what the pc looks like but no updated image.  I have switched off firewalls on both machines but the problem still exists

Cheers
0
fh87
Asked:
fh87
  • 4
  • 4
  • 2
  • +5
1 Solution
 
Ravi AgrawalCommented:
Try a shutdown / restart of the NVC server service on the Windows 7 PC. Also find the realvnc server file, right click for properties, security, check the box marked "Run as Administrator". Hit ok and test.

If no luck, Try using the Java viewer on your MAC.

http://xxx.xxx.xxx.xxx:5800 where xxx.xxx.xxx.xxx is the IP of the machine running VNC server.

Post back.

Ravi.
0
 
fh87Author Commented:
Cheers

Tried a Shutdown/Restart of VNC server.  Also made sure it was running as administrator yet still i receive a blank screen.

Tried using the java viewer to connect and this worked perfectly.

I still can't figure out why i can't view the screen using the vnc viewer app though
0
 
Ravi AgrawalCommented:
Check for firewalls blocking access to vnc application.

Ravi.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
fh87Author Commented:
all firewalls are switched off
0
 
Ravi AgrawalCommented:
Uninstall reinstall and upgrade to latest version of vnc viewer on your mac.

Ravi.
 
0
 
fh87Author Commented:
have reinstalled latest versions on both p.c. and mac
0
 
fh87Author Commented:
sorry have reinstalled on both p.c. and mac and still the same thing is happening
0
 
Ravi AgrawalCommented:
It could be some login credentials which the VNC service on the MAC is not being able to supply to Windows 7 and hence the issue. My knowledge in the area of Macs is zero (sorry), so maybe some misconfig of login credentials on your MAC. Since the Java applet is working perfectly, so there are no issues with VNC service on the Windows PC. Maybe some compatilibilty issue with VNC, Windows 7 & Mac since Windows 7  is very new.

Thats all I can think of. Try checking the user accounts section in your MAC and create one Account with same credentials that you are using on the Windows PC. Once again, check for any hidden firewall setting that may be interfering or antivirus. It could be that the firewall is allowing Port 5800 & not Port 5900. I know you said Firewalls are Off but it happens.

Better still, download teamviewer, set it to autostart & you are done. www.teamviewer.com

I am requesting the attention of Moderators, so that you can have a Mac expert can also look into the issue.

Ravi.
0
 
billmercerCommented:
Since you describe that the cursor does move remotely, this doesn't sound like a network issue to me, it sounds more like a problem with the screen capturing.

On the server side, try changing the various capture method settings.
Toggle settings like "poll for desktop changes" and "use VNC Mirror driver" then try connecting again.
On the client side, try changing the screen color depth and selecting RAW encoding.

It's possible this is related to Windows 7 compatibility. RealVNC is not currently listed as Windows 7 compatible.  You might want to try messing around with the compatibility settings.

0
 
strungCommented:
Which Mac VNC client are you using?  There are several different Mac VNC clients reviewed here:  http://www.macorchard.com/other/
0
 
DrDamnitCommented:
Problem is Aero.

Disable Aero.
Start > Control Panel > Appearnace and Personalization > Change Theme > Windows 7 Basic.

You can also try switching to UltraVNC, which will disable Aero on login.

www.uvnc.com
0
 
trekrichCommented:
This might be a little off the wall, but you could try upgrading/reloading the graphics drivers. Seems like all the options about tweaking the vnc settings and firewalls have not helped.
0
 
BarthaxCommented:
I concur with DrDamnit: Aero is the candidate.  VNC doesn't capture DirectX displays & Aero uses DirectX.
0
 
DrDamnitCommented:
Not to be a jerk about it... but... I'm right. :-)

Answer 26316019 should be accepted so the PAQ is accurate.
0
 
jhyieslaCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 4
  • 2
  • +5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now