vsphere vmnic0 down problem

Posted on 2010-01-05
Last Modified: 2013-11-09
on the host when i type esxcfg-nics -l I can see vmnic0, i can see the mac address and the the driver e1000e. But it's shown as down and half duplex. Vsphere infra client under networking I see vmnic0 but it's reporting that it's full duplex and down. But in hardware status it lists vmnic0 as false to duplex full and connection status disable.

I tried forcing the vmnic0 to 100mbps and duplex but nothing happens. I changed cables and ports and it's the same result so it's not a port or cable issue.

I also know that the nic port works as i swapped the drive out and replaced it with my windows vista OS drive and the nic works perfectly.

I don't know why or what is causing the nic to be disable. Vsphere sees it so it can't be an issue with the HCL.

Question by:iamuser
    LVL 42

    Expert Comment

    What type of physical switch is this connected to?  Check the port on the physical switch to make sure you're connected to a 1000MB port and that it's set for either auto/auto or 1000/full
    LVL 21

    Expert Comment

    how have you set the duplex settings? Using the VIC client or the using the esxcfg-nics command on the local ESX console?
    Has a power off of the ESX server been tried ... that is power off server - disconnect physically from power and then power on tried ... that could help solve the problem too!

    Author Comment

    The switch is a regular consumer 10/100. I have 2 other nica connected to the same switch both of the other nics are fine with no problems. I even swapped cables and ports with the 2 working nics

    I did power off & restart the host but that didn't do anything.

    I've used the command line on the host but it does not show any changes. Can't seem to change anything through the vi client.

    The problem is the physical nic is seen but it's not enabled just down.  
    LVL 11

    Expert Comment

    Got a similar issue, I tried forcing the port speed on a nic to 1Gb and it lost connection. Tried rebooting and powering down - still can't get it back on the LAN. Bug? Looks like I may have to re-install.

    Accepted Solution

    I could not get it to work, finally i went and redid everything from scratch, complete uninstall of vcenter, vpshere and everything. seems to work now

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Join & Write a Comment

    In this article, I am going to expose some of the hidden, undocumented, unsupported features and functions of the VMware vSphere Hypervisor (ESXi). VMware vSphere ESXi 4.x, and ESXi 5.0 does not officially support Raw Disk Mapping of Local Stora…
    #Citrix #Citrix Netscaler #HTTP Compression #Load Balance
    Teach the user how to delpoy the vCenter Server Appliance and how to configure its network settings Deploy OVF: Open VM console and configure networking:
    Teach the user how to configure vSphere clusters to support the VMware FT feature Open vSphere Web Client: Verify vSphere HA is enabled: Verify netowrking for vMotion and FT Logging is in place or create it: Turn On FT for a virtual machine: Verify …

    731 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now