Microsoft C5, database on SQL - Communication link faliure

Hi
We a huge C5 issue.
Our C5 has been changed from running on a flat database to run on a SQL server. Now the clients random gets "[ODBC SQL server driver] Communication link faliure"  

I've tried to change the SQL server hardware to a brand new HP dl180, i've installed sp3 on the sql server, i've installed a brand new PC as client, i've change the switch and the patch cables, i've tried to remove the Antivirus. But the client keeps get the Communication link faliure.

So i do not think its a hardware or network faliure anymore. But our C5 vendor keeps saying its a hardware or network faliure, could it be somekind of software error???

System information:
SQL server 2005 sp3 running on a Windows 2k3 std edition.
Microsoft Business solutions-C5 3.0 (I can't get help from microsoft because ver. 3.0 is not supported by them anymore)
Clients: WinXp pro sp3 and Windows 7.

Any suggetions will be appreciated

Regards, Steffen.
UpgradeITAsked:
Who is Participating?
 
UpgradeITConnect With a Mentor Author Commented:
Update:

I think the problem is solved.
After testing the hole network I found a switch that have a weird behavior.
It is a 8 port switch with 3 cabels connected in port 1,2,3. But the port 8 keeps blinking even throw theres no cable connected. rebooted the switch an unplugged all cabels, and the port 8 keeps blinking.
I placed a new switch insted for the old one, and it seems like the problem is gone, there have not been a problem in the last 4 hours, thats a good sign.

We have used a lot of hours on this project, my qoustion now is, is there a tool or anywhing we coud have used to see this problem before.

It seems like the switch have been sending alot of brodcast, but the network did not go totaly down, and we couldn't see anything with Wireshark.

Thanks !  
0
 
tigin44Commented:
seem like a network error. Do the host and server on the same domain? Are the network configurations correct?
0
 
UpgradeITAuthor Commented:
The host and the server?? It should be the client and the server right? And this they are in the same domain. Correct network configurations? I've have connection, its only sometimes it get the link faliure?
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
tigin44Commented:
when you ping the server how do you get the results... can you provide me a sample? I wanna know wether it resolves from dns or netbios. If the client uses netbios it may not resolve the server name...
0
 
UpgradeITAuthor Commented:
C5 (D5W32.EXE) is on a mapped network drive. And that network drive is mapped on the IP adress.
see this SS C5 is on data (Y) 192.168.0.21

http://www.myupload.dk/handleupload/c4ae9e6c61fb46cc08f681062cb0b9da1262772340

Se do you still think its a DNS / netbios error?
0
 
tigin44Commented:
Not sure... is there any other message related to this fact in the log file or event viewr?
0
 
UpgradeITAuthor Commented:
i've was thinking i the c5.ini file the connections parameters to the sql server is. And there is the server not by ip address but by netbios name (zsrvr=vollstedt.bf310d)

When I ping vollstedt-bef310d its being translated to vollstedt-bef310d.domain-name.local so it must use a DNS server, right?
0
 
UpgradeITAuthor Commented:
I got this error in the eventlog (translated from danish to english):
The program D5W32.exe version 3.0.0.0 disconnected the communication with windows and was terminated.

Proces-id: hungapp
 Starttime: 0.0.0.0
 endtime: 00000000
 program location: 4170706C69636174696F6E2048616E67202044355733322E45584520332E302E302E3020696E2068756E6761707020302E302E302E30206174206F6666736574203030303030303030
 Rapport-id: %7

source: application hang
event-id: 1002


0
 
tigin44Commented:
still I think this a dns related issue. Can you provide the dns configuration page of your network adapter?
0
 
UpgradeITAuthor Commented:
here u go --> http://www.myupload.dk/handleupload/d65b7881a00d0005b8f3acf2840b4ab21262773468

the ip 192.168.0.20 is the adress to the small business server, running ad and dns etc.
0
 
tigin44Commented:
I mean the adapter properties dns page....
0
 
UpgradeITAuthor Commented:
ehm ?? Where?
0
 
tigin44Commented:
go to the Network Adapters page. Choose your network adapter (the active one if have many). Right click on it choose properties. Navigate to the dns tab and send me the page settings...
0
 
UpgradeITAuthor Commented:
0
 
tigin44Commented:
with these settings the computer do not use the dns records. In order to use the dns records you should do some changes. Check the attached image
DNS-Settings.jpg
0
 
UpgradeITAuthor Commented:
Ehm, its standard settings?? Witch dns records are u talking about?? if I ping the computer name, the computer name is translated to an ip address so the DNS thing is working??

0
 
tigin44Commented:
I was thinking as you are... and having the same problem. At the end a microsoft speciallist analysed our network and choose our problem as this. Try my solution...
0
 
UpgradeITAuthor Commented:
OK I will do tomorrow. My domain should be my Active Directory domain right? I do only got one domain, not any secondary domain..
0
 
tigin44Commented:
sure thats right...
0
 
UpgradeITAuthor Commented:
Shit still same error.... :/

I have tried to work directly on the SQL server with remote desktop and run C5 from that server. Then there is no problem ..

Any other ideas?
0
 
UpgradeITAuthor Commented:
Can you change the default SQL servers timeout time, to prevent this error?????????
0
 
UpgradeITAuthor Commented:
Update:
The C5 is not running on SQL anymore, and the c5 is places on another server. Now we got another error  "error in delayed writing".
So it seems like theres a problem with the connections to the server, but we have tried to change everthing.

Any good suggestion?
0
All Courses

From novice to tech pro — start learning today.