[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 678
  • Last Modified:

Outlook 2007 cannot connect to Exchange

Hi,

A colleague is having a problem:
Her Outlook 2007 cannot connect to the hosted Exchange when she is connected to her home internet connection.
On any other internet connection it works a charm, without changing any settings.
On the home connection she has full internet connection & can even ping the mailserver hostname, skype, browsing, everything works... except for Outlook.
When it loads it says 'Trying to connect...' in the bottom right, can`t connect & then changes to 'Disconnected' after a minute or so.

At home she uses Virgin Media broadband & D-Link Wireless Router. (Have asked her for model number & she`s looking for it)

She has spoken to Virgin who referred her to Microsoft... needless to say she`s still waiting for MS to return her call...

I`m thinking it must be a setting in her router...? Any ideas or things that I can trouble shoot?
She is able to use OWA for now, but would very much like Outlook functionality at home in the future.

Other Details: (pretty standard)
Laptop
Windows XP
Symantec AV
Office 2007 Pro
0
Roger Adams
Asked:
Roger Adams
  • 6
  • 5
  • 2
  • +1
1 Solution
 
Alan HardistyCommented:
Is she using HTTP over RPC / Outlook Anywhere for her outlook?
If so, this only uses HTTPS and should work happily unless Virgin are blocking HTTPS!
What version of Exchange server is she trying to connect to?
0
 
Roger AdamsAuthor Commented:
> Is she using HTTP over RPC / Outlook Anywhere for her outlook?
> If so, this only uses HTTPS and should work happily unless Virgin are blocking HTTPS!
The Outlook connection to the mail server is HTTPS. Is a simple test to see if HTTPS is blocked to try accessing a HTTPS website?

> What version of Exchange server is she trying to connect to?
Exchange 2007
0
 
Alan HardistyCommented:
Yes - try using OWA via HTTPS - presumably when you say she can use OWA, it is via HTTP?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
You can also try
telnet <Exchange server\IP address> Port no
For HTTPS its 443 .... this is how you can confirm that a server can connect to another or a specific port
0
 
Roger AdamsAuthor Commented:
hmmm, she can login to OWA using HTTPS :
https://[mail].[ourserver].com/owa/ works just fine in her browser... So it`s just Outlook that is not able to establish a connection.

Does HTTPS traffic from a web browser & Outlook use the same port? Is there a chance the port Outlook uses may be blocked in the router settings if so?

I presume Virgin would have mentioned something to her on the phone this morning if they are blocking HTTPS traffic needed for Exchange... but I`m back on hold with them now to clarify this for sure...

I will get hold of her now & try the telnet connection...
0
 
Alan HardistyCommented:
Also get her to run nslookup to the FQDN of your mail server that is configured in Outlook to see if she can resolve it.
e.g., nslookup mail.yourdomain.com
0
 
Hind987Commented:
hi

Ask your ISP to allow the port for u r Public iP which is configure on u r router.
Disable u r firewall. If it is enable please allow the port in exceptions.

thanks
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
If the user isusing Outlook to connect via Internet ....... Outlook Anywhere should be functional

Is Autodiscover working ..... try
Get-OutlookAnywhere
http://technet.microsoft.com/en-us/library/bb124263%28EXCHG.80%29.aspx
Configuring Outlook Anywhere for Exchange 2007 SP1
http://www.exchange-genie.com/2008/02/configuring-outlook-anywhere-for-exchange-2007-sp1/
0
 
Roger AdamsAuthor Commented:
Tried the following:

nslookup - FQDN resolves to the correct IP address on the affected machine.

Telnet - Am able to establish a telnet connection on port 443 to the e-mail server hostname.

Virgin Media - Spoke to tech support who assured me they do not block HTTPS traffic.

Get-OutlookAnywhere - This appears to be something (looking at the links) that is initially setup on the server side, correct? Which is not possible for me to do as we have a hosted service.

Router Info - Router is a D-Link DI524 (she is now looking for the username & password to access the control panel)

Tried creating a new Outlook Profile & adding the account using Autodiscover - Everything goes well, Outlook appears to be able to find the information it needs & then comes back saying it cannot connect to the server. It displays the settings it is using, all of which appears to be correct. But there is still something 'blocking' Outlook from connecting to the server.

Run Outlooks 'Test E-mail  Autoconfiguration' - Enter the e-mail address & password, click OK. Wait  ed a few minutes, it prompted me for e-mail address & password in a normal Outlook dialog... then after about 5 minutes dumped all the info it found. All of which appeared to be correct.

Took a screen shot of what Outlook 'Connection Status' window looks like... see attached
Also took a screen shot of my working 'Connection Status' (account hosted on the same server).. also see attached

Any ideas of what further I can check?
Thanks for all the help so far!!
wrong-connection-status.PNG
working-connection-status.PNG
0
 
Alan HardistyCommented:
If you try to connect to her router via https:\\herIPaddress, do you see the router login screen?
If you do, this may mean that HTTPS is being re-directed to her router and not through her router.
Presumably when she is anywhere else other than her present non-working location she is fine?
0
 
Roger AdamsAuthor Commented:
when attempting to access https://[herIPaddress] it takes some time & then says the connection has timed out, no router login request page.

> Presumably when she is anywhere else other than her present non-working location she is fine?
Yep, anywhere else everything (including Outlook) works perfectly.
0
 
Alan HardistyCommented:
It certainly does sound router related.  Don't suppose she has a spare knocking about?
If not, might be worth checking / upgrading the firmware.  Latest version is 2.06b02
http://www.dlink.co.uk/cs/Satellite?c=TechSupport_C&childpagename=DLinkEurope-GB%2FDLTechProduct&cid=1197319373334&p=1197318962293&packedargs=locale%3D1195806691854&pagename=DLinkEurope-GB%2FDLWrapper 
0
 
Roger AdamsAuthor Commented:
She doesn`t have a spare I`m afraid...
I need her to come up with the username & password to get access to the router config page...

hmmm, to further explain her setup at home (whilst I wait for her to find the credentials):
Phone line ---> Internet Modem Supplied by Virgin ---> Ethernet Cable ---> D-Link Router ---> Wireless ---> Laptop

(Just in case something in that chain could also be another possible point to troubleshoot)
0
 
Alan HardistyCommented:
Okay - so is the Virgin box just a modem?  I have a relative who have a NetGear router, so this means if you have the same, that there are two routers which will complicate issues.
If this is the case, might be better off long-term using a wireless access point instead.
 
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

  • 6
  • 5
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now