sshd services can't start

Dear Sir i have SUSE 9.0 system iand i have a problem with the sshd service

when i try to start it with command " rcsshd start"
it's failed with error message from shell :

Starting SSH daemonExtra argument root.
 exit status of parent of /usr/sbin/sshd:1

i tried to remove an reinstall the package of sshd but no way

so can anybody tell me what i can do to solve this problem
asfourcrystalAsked:
Who is Participating?
 
arnoldConnect With a Mentor Commented:
grep sshd  /var/log/messages
See if you have an error that could clear things up.
after you run the test suggested aboev by legolasthehansy, if sshd was not running, you can start it in debug mode:
/usr/sbin/sshd -v


See what it is reporting as errors if there is anything.
Double check the config /etc/ssh/sshd_config to make sure the port to which it binds is 22 and not something else if someone other than you manages/managed this system.
0
 
legolasthehansyCommented:
Try giving only rcsshd and see what happens.
0
 
asfourcrystalAuthor Commented:
sorry what do you mean by giving only rcsshd????
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
legolasthehansyCommented:
All standard executeables should be under /etc/init.d

Try this,
cd /etc/init.d
./sshd start

Or see if there is any instances of sshd's running.
ps -ef | grep sshd

kill it and then restart and check
0
 
asfourcrystalAuthor Commented:
it try with same error
0
 
arnoldCommented:
you used the -v flag and the same two lines are the only information displayed?

Was sshd running and you had to terminate the process or it was not running ?
strace -f -p /usr/sbin/sshd
0
 
asfourcrystalAuthor Commented:
this time when i try to start the services it return

Starting SSH daemonExtra argument root.
startproc:  exit status of parent of /usr/sbin/sshd: 1
                                                                     done

but when i try to restart it it give failed
0
 
arnoldCommented:
Could you look in /var/log/messages to see if anything is being reported there?
Did ssh ever work on this system?
0
 
AmolCommented:
It may be a generic error, usually because invalid command line options or malformed configuration
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.