no free/busy information could be retrieved

Recently we upgraded to a new email server.  We went from Exchange 2000 to Exchange 2007.  Since that time, users who have Outlook 2003 and earlier are getting "no free/busy information could be retrieved" when trying to view shared calendars.  I've been reading and apparently we need to setup Free/Busy Public Folders or something to that effect... I am just not sure how to do that.  Anyone have any ideas on this issue?  Is the aforementioned folder creation the answer or is there something else we can do to resolve this?  
LVL 1
MemberMindedAsked:
Who is Participating?
 
shauncroucherConnect With a Mentor Commented:
When you migrated from 2000 to 2007 you should have replicated your public folder store to Exchange 2007.

What you will have to do now if the Exchange 2000 is no longer in the organisation is to regenerat the free/busy info and YES, you will need a public folder to hold the free/busy for Outlook 2003 and earlier.

Mount a public folder store in your organisation and then Outlook clients should regenerate every 15 mins. You can run the /Cleanfreebusy switch from outlook to force a regeneration. this will need to be done on all clients.

http://www.petri.co.il/outlook_2003_command_line_switches.htm

Shaun

0
 
MemberMindedAuthor Commented:
Hm.  I just checked EMC and it looks as if there is a Schedule Free/Busy public folder already there.  Is there something I am missing here?  (I am a newbie to Exchange 2007..sorry)
0
 
Narayan_singhConnect With a Mentor Commented:
As "Shaun" said make sure public folders are replicated for users to be able to see their FB info which was posted when their mailboxes were in Ex 2003. so set the replication on ESM 2003 set Ex 2007's public folder in a replica list

Go to Exchange management cnsole > tool b ox > public folder management>
go to system folder >schedule+ free busy under this do you have EX:/o=ORG NAME/ou=first Administrative Group
you should have two folders one for e2k7 and one for legacy admin group

post back
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
MemberMindedAuthor Commented:
There are two folders listed in the file tree.  I am attaching a screenshot of what I see.  
exchange-folders.JPG
0
 
maumenCommented:
Check the Finalize Deployment tab in Exchange Management Console (EMC) to be sure you haven't missed anything then run the Exchange Best Practice Analyzer's (ExBPA) Health Check from the Toolbox.
0
 
MemberMindedAuthor Commented:
I noticed this when I went to the properties for the folder that ends in /ou=CHAMBER ....under the REPLICATION tab, the server that is listed there (gli-ex2k-2) is the old Exchange 2000 server that has been decommissioned and is no longer on the domain.  Should this entry be changed by chance?
exchange-folders-2.JPG
0
 
Narayan_singhCommented:
Yes you should have only ex 2007 server listed there ..... did you try to follow the article and verify if thereplica is set... if not set please set the replica.....
sorry here is the article
http://blogs.microsoft.co.il/blogs/dand/archive/2009/07/08/users-who-use-outlook-2003-cannot-publish-their-free-busy-data-in-exchange-server-2007.aspx
once you set that and remove old server from there it should work if doesnt we will check sitefolderserver attribute
0
 
MemberMindedAuthor Commented:
I went in to change that from the old to new server.  The only options I have to select from are the two folders that already exist.  There doesn't seem to be a place to edit where that folder points to.  Maybe I'm going about this all wrong... I use to think I was fairly intelligent :-P
exchange-folders-3.JPG
0
 
Narayan_singhCommented:
if the server GLI-EX2k doesnt exist remove it and from above attachment just selct above one ( i assume that ex 2007) and click ok.
0
 
shauncroucherCommented:
The public folder that you see in the list is the free busy for the Exchange 2007 organisation, not the legacy 2000 org. You missed a step when migrating the Exchange 2000, and that was to migrate the PF data.  

Have you tried running the /cleanfreebusy switch on the client PC's - this will republish the freebusy info into the existing public folder database.

Shaun
0
 
MemberMindedAuthor Commented:
i just now tried to run the cleanfreebusy switch...  in the run box I typed:

"C:\Program Files\Microsoft Office\OFFICE11\Outlook.exe" /CleanFreeBusy

All that does is open Outlook.  Is it suppose to do that, or is there another way of getting verification that the switch was successful?
0
 
shauncroucherCommented:
Yes, thats it, but it will force the client to publish free/busy info to the public folder.

Can you use mangement shell or public folder management console to see how many items there are in the free/busy folder.

You will need to repeat for every client. There is a way to do this for all mailboxes, but I can't find the reference to the method involved, another expert may know.

Shaun
0
 
MemberMindedAuthor Commented:
does this switch work for Outlook XP/2000 users as well?  We (unfortunately) have a few users still on those platforms.
0
 
shauncroucherCommented:
Yes, available in 97 and up.

Shaun
0
 
MemberMindedAuthor Commented:
Excellent.  I'll give this a try and get back you helpful people with the results!
0
 
MemberMindedAuthor Commented:
I ran the cleanfreebusy switch on one of the client computers but it doesnt work... i get a pop-up with a progress bar saying "retrieving information from gli-ex2k-2" ....the progress bar goes to the end, it closes, and then starts all over again.  "GLI-EX2K-2" is our old email server, so I'm not sure why it is still trying to pull data from it there....
0
 
shauncroucherCommented:
Have you set the mailbox database that holds the mailbox to use the Exchange 2007 public folder as default?

http://technet.microsoft.com/en-us/library/bb629522.aspx

Can you create a public folder from the exchange management console (public foldr management tool) and then see if you can access this from the outlook client.

Does it work on any of them?

Shaun
0
 
MemberMindedAuthor Commented:
I created a folder called "Test Folder" under the Default Public Folders in the Public Folder Management Tool... am able to see the folder from outlook.  
0
 
MemberMindedAuthor Commented:
shauncroucher:

It appears that the mailbox database is pointing to the Exchange 2007 email server (gli-ex2k8-3) public folder.  
exchange-folder-4.JPG
0
 
MemberMindedAuthor Commented:
I went to:

http://blogs.microsoft.co.il/blogs/dand/archive/2009/07/08/users-who-use-outlook-2003-cannot-publish-their-free-busy-data-in-exchange-server-2007.aspx

..and followed the instructions.  In the shell I ran the command it asked for and I got an error.  See image for details.
exchange-shell.JPG
0
 
Narayan_singhCommented:
CMD that you runningis wrong it should be something like
set-publicfolder -Identity "\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=urorgname/ou=Legacy Administrative Group" -replicas "Server\Second Storage Group\Public Folder Database"

Where
"urorganme" is Exchange organization .
legacyadmin group name is exchange 2003 server's admin group name which in your case i suppose is chamber

long story short

This "\EX:/o=urorgname/ou=Legacy Administrative Group" has to be one of those folders (the top one) that you see under Schedule+ free busy folder in PF management folder .

run the command again post back if any isssues
0
 
MemberMindedAuthor Commented:
Issue resolved by executing that command correctly!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.