[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 209
  • Last Modified:

External USB HDD crashing system

It was mentioned in the resolution of this issue that the cause was the Pervasive Sql driver was causing the issue. I have a similar issue with one of my servers and would like to know how to investigate the above possibility as i have exhausted all other avenues.
0
joe-soap
Asked:
joe-soap
1 Solution
 
tbsgadiCommented:
0
 
joe-soapAuthor Commented:
Hi guys

I have finally resolved the issue and it was indeed the pervasive Sql causing the problem. I took the lead from one of the posts and then proceeded to download the latest service pack for the pervaisive which is SP3. I installed this rebooted the server and VOILA it worked problem sorted.

This problem only seems to manifest itself in Ver 10 of pervasive. I hope this information helps others out there that are experiencing this issue.
0
 
mirtheilCommented:
Here is a KB that explains the issue:
http://ww1.pervasive.com/kb/kb.asp?fx=getdetails&solid=00018067&title=xio%20interferes%20with%20mounting%20of%20external%20ntfs%20volume

The description from the KB article:
The reported problem is that external PNP (Plug-and-Play) devices formatted with NTFS that are installed after XIO is started (ex. Removable USB hard disk device) are not mounted correctly. Devices installed before XIO is started during boot-time will be mounted along with other non-removable disks.  

As stated, this is resolved in SP3.  This also only affects 32 bit servers.  It does not affect 64 bit servers.
0

Featured Post

Transaction-level recovery for Oracle database

Veeam Explore for Oracle delivers low RTOs and RPOs with agentless transaction log backup and transaction-level recovery of Oracle databases. You can restore the database to a precise point in time, even to a specific transaction.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now