Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

IIS 6 doesn't allow me to open .aspx files

Posted on 2010-01-06
28
Medium Priority
?
681 Views
Last Modified: 2012-06-21
html files it open's no problem.

but for aspx files in the very same folder does not open the error is attached.
my machine is a windows server 2003 64bit.
an help??

Thanks!
The page cannot be found

The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.
Please try the following:

Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.
If you reached this page by clicking a link, contact the Web site administrator to alert them that the link is incorrectly formatted.
Click the Back button to try another link.
HTTP Error 404 - File or directory not found.
Internet Information Services (IIS)

Technical Information (for support personnel)

Go to Microsoft Product Support Services and perform a title search for the words HTTP and 404.
Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Web Site Setup, Common Administrative Tasks, and About Custom Error Messages.

Open in new window

0
Comment
Question by:JustAskMe
  • 9
  • 9
  • 5
  • +1
28 Comments
 
LVL 71

Expert Comment

by:Chris Dent
ID: 26192051

Sounds rather like the extension is prohibited. Go to Web Service Extensions and see if it's permitted (or if there's even an option to permit it)?

Chris
0
 

Author Comment

by:JustAskMe
ID: 26192070
I checked that active pages is permitted !

What else can I try?
0
 
LVL 71

Expert Comment

by:Chris Dent
ID: 26192095

Active Server Pages will give you .asp, not .aspx. There should be an explicit entry for .NET in the web service extensions folder. If there isn't you might want to re-register the IIS part of the .NET framework.

That should be:

aspnet_regiis -i

Where aspnet_regiis is in the .NET Framework folder.

Chris
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 

Author Comment

by:JustAskMe
ID: 26192129
Thanks for that info.

but how do I add it?
0
 

Author Comment

by:JustAskMe
ID: 26192137
When I click add I dont see a dll with this name aspnet_regiis -i
0
 
LVL 71

Expert Comment

by:Chris Dent
ID: 26192202

Sorry, I wasn't very clear. It's an executable, it fires up the installer and makes it register ASP .NET with IIS. That should, once it's done, leave you with a Web Service Extension called "ASP .NET <version>".

You should be able to invoke it by using Start, Run then:

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i

Alternative, fire up the command prompt, head to that directory and execute it there.

Chris
0
 
LVL 11

Expert Comment

by:princeatapi
ID: 26192225
0
 
LVL 71

Expert Comment

by:Chris Dent
ID: 26192235

There's a full description of the tool here, so you don't have to take my word entirely about why I'm asking you to run it:

http://msdn.microsoft.com/en-us/library/k6h9cz8h%28VS.80%29.aspx

Chris
0
 
LVL 61

Expert Comment

by:Kevin Cross
ID: 26192246
I agree with Chris.  You can go under Web Extensions and enable ASP.NET; however, it is easier to do as intructed with the aspnet_regiis.  What you do is open a command prompt and navigate to %windir%\Microsoft.NET\Framework\{your version}

The aspnet_regiis.exe file is in there.  The -i is a command line switch for "install".  :) This will register your .NET with IIS properly.
0
 
LVL 71

Accepted Solution

by:
Chris Dent earned 668 total points
ID: 26192249

heh, sorry princeatapi, I need to glue refresh down :)

Chris
0
 
LVL 61

Expert Comment

by:Kevin Cross
ID: 26192256
Oh, I type too slow.  Chris already posted it.  Nice work, sir.
0
 

Author Comment

by:JustAskMe
ID: 26192269
Thanks all people for your great help

now they changed the error :(
Server Error in '/' Application.

The current identity (NT AUTHORITY\NETWORK SERVICE) does not have write access to 'C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files'.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.Web.HttpException: The current identity (NT AUTHORITY\NETWORK SERVICE) does not have write access to 'C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files'.

Source Error: 

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace: 


[HttpException (0x80004005): The current identity (NT AUTHORITY\NETWORK SERVICE) does not have write access to 'C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files'.]
   System.Web.HttpRuntime.SetUpCodegenDirectory(CompilationSection compilationSection) +1036
   System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags) +409

[HttpException (0x80004005): The current identity (NT AUTHORITY\NETWORK SERVICE) does not have write access to 'C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files'.]
   System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +709
   System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +317
   System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +595

Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42

Open in new window

0
 
LVL 61

Assisted Solution

by:Kevin Cross
Kevin Cross earned 668 total points
ID: 26192297
Just fix the permissions issue.  You can grant Network Service the appropriate rights to the .NET framework temporary files directory as stated, but alternatively as I typically do is to have IIS on a separate drive and configure IIS (website and defaults) to use a temporary directory for ASP.NET files on that same volume to which I have already granted appropriate permissions.  That way I don't have to mess with default (more secure) configuration of C: (OS volume) that now ships with Windows Server 2003 or higher (plus it was always good practice to run IIS this way and delete C:\Inetpub).
0
 
LVL 11

Expert Comment

by:princeatapi
ID: 26192318
Chris-Dent:

 All right Chris ..  
0
 
LVL 71

Expert Comment

by:Chris Dent
ID: 26192326

Mine are the same, I leave the system disk for the system, anything web sites require lives on a separate volume.

At least it's execute ASP .NET now, even if that's not working very well :)

Chris
0
 

Author Comment

by:JustAskMe
ID: 26192364
Thanks for the help!

Can some one explane how I give permission for NT AUTHORITY\NETWORK SERVICE to write to that temp folder?
0
 
LVL 11

Assisted Solution

by:princeatapi
princeatapi earned 664 total points
ID: 26192402
0
 
LVL 61

Expert Comment

by:Kevin Cross
ID: 26192408
This might be a good read for you:
http://msdn.microsoft.com/en-us/library/aa302396.aspx
 
 As far as step 3 and your issue (assigning NTFS permissions), the simple answer is to right-click on the folder and select security (properties | security tab) and then add Network Service and check appropriate permissions.  Per document linked, full control is suggested (modify - everything but FULL which allows setting of permissions - should be enough).
 
0
 
LVL 71

Expert Comment

by:Chris Dent
ID: 26192432

Sure.

1. Open up Windows Explorer, or whatever you want to browse the file system.
2. Navigate to C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727
3. Right click on "Temporary ASP.NET Files" and open Properties
4. Select the Security Tab
5. Click Add
6. Enter "Network Service" (doesn't matter what it says for Location)
7. Click OK
8. Select the new entry in the list, and tick boxes at the bottom to give it write access

Chris
0
 

Author Comment

by:JustAskMe
ID: 26192531
Thanks for all your help

every error that goes away a new one is created :(

now the error is :
Server Error in '/' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

Parser Error Message: Child nodes not allowed.

Source Error: 


Line 102:		<compilers>
Line 103:			<compiler language="c#;cs;csharp" extension=".cs" warningLevel="4" type="Microsoft.CSharp.CSharpCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
Line 104:				<providerOption name="CompilerVersion" value="v3.5"/>
Line 105:				<providerOption name="WarnAsError" value="false"/>
Line 106:			</compiler>

Source File: E:\Test\Test WebService\web.config    Line: 104 

Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42

Open in new window

0
 

Author Comment

by:JustAskMe
ID: 26192537
BTW I use vb not c#
0
 

Author Comment

by:JustAskMe
ID: 26192580
Never mind... It works!

how do I split the points here?

so many people helped :)
0
 
LVL 71

Expert Comment

by:Chris Dent
ID: 26192587

It's quoting something from web.config, which presumably you generated and uploaded as part of your application?

Visual Studio, in my experience, normally fill those bits in quite nicely provided you tell it the correct language when you first create the project. I doubt there's anything there that can't be manually changed though.

Chris
0
 
LVL 11

Expert Comment

by:princeatapi
ID: 26192598
i believe you can remove that
0
 
LVL 71

Expert Comment

by:Chris Dent
ID: 26192613

Ignore that post above then :)

Three way split if you use Accept Multiple Solutions?

Works out at 166, 167 and 167 points if you're going for equality, I doubt anyone is particularly bothered about how that's arranged :)

Chris
0
 

Author Closing Comment

by:JustAskMe
ID: 31673576
Thanks All
0
 
LVL 11

Expert Comment

by:princeatapi
ID: 26192686
No issues Chris-Dent:  :)  
0
 
LVL 61

Expert Comment

by:Kevin Cross
ID: 26192709
Thanks for sharing the points, Chris.  IMHO, you probably deserved it all for answering the question as it reads above, but appreciate the generosity for efforts in assisting (chiming in) on secondary questions.  It was definitely my pleasure to help, but also be in a thread with folks like you.

Thanks again for the points.

Best regards and happy coding,

Kevin
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Setting up a Microsoft WSUS update system is free relatively speaking if you have hard disk space and processor capacity.   However, WSUS can be a blessing and a curse. For example, there is nothing worse than approving updates and they just have…
If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
Loops Section Overview

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question