PlayStation 3 doesn't connect to internet anymore.

Hello,

a playstation is connected to a Cisco router.
It was working everything fine when suddenly it disconnected from the internet.

The cable is good, and the router is fine in configuration and hardware.

The error in the PS3 says: IP Address: Failed
It cannot get an IP address...

Please tell me what and where can be the problem... and how to resolve it..

Here is the output of the DHCP packet debug (taken when just started testing the internet connection with the PS3, where it says that it couldn't get an IP):

*Dec 17 02:15:38.429: DHCPD: DHCPRELEASE message received from client 0100.1d0d.b65b.d6 (192.168.1.18).
*Dec 17 02:15:38.429: DHCPD: Sending notification of TERMINATION:
*Dec 17 02:15:38.429:  DHCPD: address 192.168.1.18 mask 255.255.255.0
*Dec 17 02:15:38.429:  DHCPD: reason flags: RELEASE 
*Dec 17 02:15:38.429:   DHCPD: htype 1 chaddr 001d.0db6.5bd6
*Dec 17 02:15:38.429:   DHCPD: lease time remaining (secs) = 86324
*Dec 17 02:15:38.429: DHCPD: returned 192.168.1.18 to address pool Home_PCs.
*Dec 17 02:15:39.938: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2, changed state to down
*Dec 17 02:15:40.942: %LINK-3-UPDOWN: Interface FastEthernet2, changed state to down
*Dec 17 02:15:43.122: %LINK-3-UPDOWN: Interface FastEthernet2, changed state to down
*Dec 17 02:15:46.343: %LINK-3-UPDOWN: Interface FastEthernet2, changed state to up
*Dec 17 02:15:47.343: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2, changed state to up
*Dec 17 02:16:02.819: DHCPD: checking for expired leases.
*Dec 17 02:16:16.290: DHCPD: Sending notification of DISCOVER:
*Dec 17 02:16:16.290:   DHCPD: htype 1 chaddr 001d.0db6.5bd6
*Dec 17 02:16:16.290:   DHCPD: remote id 020a0000c0a80101f1000000
*Dec 17 02:16:16.290:   DHCPD: circuit id 00000000
*Dec 17 02:16:16.290: DHCPD: DHCPDISCOVER received from client 0100.1d0d.b65b.d6 on interface BVI1.
*Dec 17 02:16:16.294: DHCPD: Seeing if there is an internally specified pool class:
*Dec 17 02:16:16.294:   DHCPD: htype 1 chaddr 001d.0db6.5bd6
*Dec 17 02:16:16.294:   DHCPD: remote id 020a0000c0a80101f1000000
*Dec 17 02:16:16.294:   DHCPD: circuit id 00000000
*Dec 17 02:16:16.294: DHCPD: Allocate an address without class information (192.168.1.0)
*Dec 17 02:16:18.294: DHCPD: Adding binding to radix tree (192.168.1.19)
*Dec 17 02:16:18.294: DHCPD: Adding binding to hash tree
*Dec 17 02:16:18.294: DHCPD: assigned IP address 192.168.1.19 to client 0100.1d0d.b65b.d6.
*Dec 17 02:16:18.294: DHCPD: Sending DHCPOFFER to client 0100.1d0d.b65b.d6 (192.168.1.19).
*Dec 17 02:16:18.294: DHCPD: creating ARP entry (192.168.1.19, 001d.0db6.5bd6, vrf 0).
*Dec 17 02:16:18.294: DHCPD: unicasting BOOTREPLY to client 001d.0db6.5bd6 (192.168.1.19).
*Dec 17 02:16:18.294: DHCPD: DHCPREQUEST received from client 0100.1d0d.b65b.d6.
*Dec 17 02:16:18.294: DHCPD: Sending notification of ASSIGNMENT:
*Dec 17 02:16:18.294:  DHCPD: address 192.168.1.19 mask 255.255.255.0
*Dec 17 02:16:18.298:   DHCPD: htype 1 chaddr 001d.0db6.5bd6
*Dec 17 02:16:18.298:   DHCPD: lease time remaining (secs) = 86400
*Dec 17 02:16:18.298: DHCPD: Can't find any hostname to update
*Dec 17 02:16:18.298: DHCPD: Sending DHCPACK to client 0100.1d0d.b65b.d6 (192.168.1.19).
*Dec 17 02:16:18.298: DHCPD: creating ARP entry (192.168.1.19, 001d.0db6.5bd6, vrf 0).
*Dec 17 02:16:18.298: DHCPD: unicasting BOOTREPLY to client 001d.0db6.5bd6 (192.168.1.19).
*Dec 17 02:18:02.822: DHCPD: checking for expired leases.

Open in new window

LVL 5
ping_itAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Vito_CorleoneCommented:
It appears to be getting one. Is that MAC correct for the PS3? Is the .19 address pingable?
0
ping_itAuthor Commented:
WOW, that's amazing!!

The playstation seems to START trying to get an IP address... but on the router no traffic, just the interface goes down and up.

Then, after many seconds in the playstation appears the message that it failed to get the IP address with the error message "the attempt to obtain an IP address timed out".

After 1-2 second, I start seeing dhcp packets on the cisco router!!!

What does it mean?!?!  that even if in the PS3 there is the message that it failed, the IP address is given to the PS, but the error message remains.

I know the PS accepts it, because I can ping it!!!

But there is the error message and when I exit from this screen, the PS sends the:

*Dec 17 03:45:32.876: DHCPD: DHCPRELEASE message received from client 0100.1d0d.b65b.d6 (192.168.1.15).
*Dec 17 03:45:32.876: DHCPD: Sending notification of TERMINATION:


What to do? It seems that it is taking too long to give the IP address, or the PS is waiting too little time...

Please help



0
Vito_CorleoneCommented:
This might be silly, but have you rebooted the PS3? The router shouldn't need it, but you could try that too. Everything looks like it's working on the router side. Maybe you could try a static IP on the PS3?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

ping_itAuthor Commented:
I am trying already several days, and both router and ps have been restarted several times :/

I can try a static IP, but for some internal policy I need to use dynamic ip addressing
0
JstncaseCommented:
Has the MAC address of the PS3 been blocked or filtered any place on the Cisco? Has a static entry been put into the Cisco router for the PS3, but the IP is already in use?
0
Vito_CorleoneCommented:
Can you post a "sh run" from the Cisco please.
0
ping_itAuthor Commented:
Jstncase: no/no.

Vito: yes





Building configuration...

Current configuration : 4810 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname xxxxxxxx
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 xxxxxxxxxxxxx
!
aaa new-model
!
!
aaa authentication login VPN-LIST local
aaa authorization network VPN-NET-GROUP local 
!
!         
aaa session-id common
clock timezone Warsaw 1
clock summer-time Warsaw date Mar 30 2003 2:00 Oct 26 2003 3:00
!
crypto pki trustpoint TP-self-signed-xxxx
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-xxxx
 revocation-check none
 rsakeypair TP-self-signed-xxxx
!
!
crypto pki certificate chain TP-self-signed-xxxx
 certificate self-signed 01
xxxxxxxxxxxx
        quit
dot11 syslog
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.9
ip dhcp excluded-address 192.168.1.21 192.168.1.254
!
ip dhcp pool Home_PCs
   import all
   network 192.168.1.0 255.255.255.0
   dns-server 212.76.39.211 212.76.39.205 
   default-router 192.168.1.1 
!
!
ip cef    
ip domain name yourdomain.com
!
!
!
username xxx privilege 15 secret 5 xxxx
username xxx password 0 xxx
! 
!
crypto isakmp policy 3
 encr 3des
 authentication pre-share
 group 2
crypto isakmp keepalive 10
!
crypto isakmp client configuration group vpngroup
 key cisco123
 dns 212.76.39.211 212.76.39.206
 pool ippool
!
!
crypto ipsec transform-set myset esp-3des esp-sha-hmac 
!
crypto dynamic-map dynmap 10
 set transform-set myset 
 reverse-route
!
!
crypto map clientmap client authentication list VPN-LIST
crypto map clientmap isakmp authorization list VPN-NET-GROUP
crypto map clientmap client configuration address respond
crypto map clientmap 10 ipsec-isakmp dynamic dynmap 
!
crypto ctcp port 888 
archive
 log config
  hidekeys
!
!
ip ssh time-out 60
ip ssh version 2
!
!
!
interface Loopback0
 ip address 10.11.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface FastEthernet0
 description To Cisco PC
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 ip policy route-map VPN-Client
 duplex auto
 speed auto
 crypto map clientmap
!
interface Dot11Radio0
 no ip address
 shutdown 
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
ip local pool ippool 192.168.5.2 192.168.5.3
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 5 life 86400 requests 10000
ip nat inside source list 101 interface FastEthernet4 overload
!
access-list 1 remark SDM_ACL Category=16
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
access-list 101 permit ip 10.11.0.0 0.0.0.255 any
access-list 101 permit ip 192.168.5.0 0.0.0.255 any
access-list 144 permit ip 192.168.5.0 0.0.0.255 any
route-map VPN-Client permit 10
 match ip address 144
 set ip next-hop 10.11.0.2
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 password xxx
 transport input telnet ssh
!
scheduler max-task-time 5000
end

Open in new window

0
Vito_CorleoneCommented:
The config looks fine to me. This might be a longshot, but you could try giving it a static DHCP reservation, then do another debug and see what happens.

ip dhcp pool PS3
   host 192.168.1.25 255.255.255.0
   client-identifier 0100.1d0d.b65b.d6

Verify that MAC address.

0
ping_itAuthor Commented:
Vito, are you sure that it should be host 192.168.1.25 255.255.255.0 and not 255.255.255.255?

P.s. yes, I will double check the MAC
0
Vito_CorleoneCommented:
Yes, you're telling it which subnet mask to give the host, you're not matching the IP or anything.
0
ping_itAuthor Commented:
oh yes, it's a mask, not a wildcard
0
Sacrificial_LambCommented:
I haven't already tried, try bypassing hte cisco router completly to access the internet.  If it works it may confirm that the issue is with the cisco router somehow and not another variable.
0
ping_itAuthor Commented:
It is not getting the IP as supposed:

I have configured this:

ip dhcp pool PS3
   host 192.168.1.20 255.255.255.0
   client-identifier 001d.0db6.5bd6


And here what happens:

*Dec 17 04:50:55.413: %LINK-3-UPDOWN: Interface FastEthernet2, changed state to up
*Dec 17 04:50:56.413: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2, changed state to up
*Dec 17 04:51:26.896: DHCPD: Sending notification of DISCOVER:
*Dec 17 04:51:26.896:   DHCPD: htype 1 chaddr 001d.0db6.5bd6
*Dec 17 04:51:26.896:   DHCPD: remote id 020a0000c0a80101f1000000
*Dec 17 04:51:26.896:   DHCPD: circuit id 00000000
*Dec 17 04:51:26.896: DHCPD: DHCPDISCOVER received from client 0100.1d0d.b65b.d6 on interface BVI1.
*Dec 17 04:51:26.896: DHCPD: Seeing if there is an internally specified pool class:
*Dec 17 04:51:26.896:   DHCPD: htype 1 chaddr 001d.0db6.5bd6
*Dec 17 04:51:26.896:   DHCPD: remote id 020a0000c0a80101f1000000
*Dec 17 04:51:26.896:   DHCPD: circuit id 00000000
*Dec 17 04:51:26.896: DHCPD: Allocate an address without class information (192.168.1.0)
*Dec 17 04:51:28.897: DHCPD: Adding binding to radix tree (192.168.1.19)
*Dec 17 04:51:28.897: DHCPD: Adding binding to hash tree
*Dec 17 04:51:28.897: DHCPD: assigned IP address 192.168.1.19 to client 0100.1d0d.b65b.d6.
*Dec 17 04:51:28.897: DHCPD: Sending DHCPOFFER to client 0100.1d0d.b65b.d6 (192.168.1.19).
*Dec 17 04:51:28.897: DHCPD: creating ARP entry (192.168.1.19, 001d.0db6.5bd6, vrf 0).
*Dec 17 04:51:28.897: DHCPD: unicasting BOOTREPLY to client 001d.0db6.5bd6 (192.168.1.19).
*Dec 17 04:51:28.897: DHCPD: DHCPREQUEST received from client 0100.1d0d.b65b.d6.
*Dec 17 04:51:28.897: DHCPD: Sending notification of ASSIGNMENT:
*Dec 17 04:51:28.897:  DHCPD: address 192.168.1.19 mask 255.255.255.0
*Dec 17 04:51:28.897:   DHCPD: htype 1 chaddr 001d.0db6.5bd6
*Dec 17 04:51:28.897:   DHCPD: lease time remaining (secs) = 86400
*Dec 17 04:51:28.897: DHCPD: Can't find any hostname to update
*Dec 17 04:51:28.897: DHCPD: Sending DHCPACK to client 0100.1d0d.b65b.d6 (192.168.1.19).
*Dec 17 04:51:28.901: DHCPD: creating ARP entry (192.168.1.19, 001d.0db6.5bd6, vrf 0).
*Dec 17 04:51:28.901: DHCPD: unicasting BOOTREPLY to client 001d.0db6.5bd6 (192.168.1.19).
*Dec 17 04:52:03.004: DHCPD: checking for expired leases.

Open in new window

0
Vito_CorleoneCommented:
Ah, one thing I didn't mention. You will likely need to clear the least on that IP before it will use the reservation. So:

clear ip dhcp bind 192.168.1.19

That should clear it out and free the MAC for the reservation.
0
ping_itAuthor Commented:
Something wrong is going on?

Please look at this:

#sh ip dhcp bind
192.168.1.13        0100.1d0d.b65b.d6       Dec 22 2009 12:17 AM    Automatic
192.168.1.20        001d.0db6.5bd6          Infinite                Manual

In the PS3 settings I can see that the right MAC address is  001d.0db6.5bd6, but why the PS3 is using a so long IP address? (it is getting 192.168.1.13 from DHCP).
0
Vito_CorleoneCommented:
You need to use "client-identifier" in your DHCP reservation:

ip dhcp pool PS3
   host 192.168.1.20 255.255.255.0
   client-identifier 0100.1d0d.b65b.d6

Remove the old reservation and paste that one in. Then do "clear ip dhcp bind *" and pull the new IP with the PS3.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ping_itAuthor Commented:
yes it works, thanks...

by the way... why such a long MAC address??? is that rigth? possible?
0
Vito_CorleoneCommented:
Cisco uses "client identifiers" with DHCP, where the router will prepend a two digits to the MAC address. I don't know what the reasoning for this is, just that it is.

Glad I could help with your issue!
0
ping_itAuthor Commented:
Many thanks...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Game Consoles

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.