• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 638
  • Last Modified:

Can't delete desktop icons in Windows 2003 Server remote session

I have a Windows 2003 server that employees (non-admin) remote into to use software. There are several icons on the employees' desktops that I want to remove but I don't know how. When I delete under their login it says access denied. If I browse to their desktop directory while admin the icons don't appear. How do I delete these?

Thank you!
0
itsofmi
Asked:
itsofmi
  • 3
2 Solutions
 
bank_on_itCommented:
Give a user temporary admin rights.
Login as them.
Delete icons.
Remove admin rights from user.
0
 
bank_on_itCommented:
If you do not want to give the rights.
Try going into each users profiles and open up the Desktop folders and delete from there.
0
 
Sacrificial_LambCommented:
Rather than browse to their individual profiles on the local machines, browse to "C:\Documents and Settings\All Users" and delete the icons from there.  Quite a few applications and default OS installs will add desktop shortcuts to the "All Users" profile and individual users may not have the rights to remove these.
0
 
bank_on_itCommented:
Just had this issue with Windows 7, I was able to fix by logging in and granting them full rights to all the shortcuts and by making them a "Power User." You may also want to look at the inheritable permissions from the parent folder, there may be something off in there.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now