Another easy permissions question.

When I create a file through bash, it is readable by apache, and can be displayed. When I upload a file via ftp (using the same useraccount) it is not. See directory listing below.

How do I fix this?

Server: Ubuntu
FTP Server: VSFTP
hphinc@backup01:~/www$ ls -lah
total 16K
drwxr-xr-x 2 hphinc hphinc 4.0K 2010-01-06 18:34 .
drwxr-xr-x 3 hphinc hphinc 4.0K 2010-01-06 18:33 ..
-rw-r--r-- 1 hphinc hphinc   21 2010-01-06 18:33 index.php
-rw------- 1 hphinc hphinc   44 2010-01-06 18:34 test.php

Open in new window

LVL 32
DrDamnitAsked:
Who is Participating?
 
hemmiCommented:
umask in /etc/vsftpd.conf
0
 
DrDamnitAuthor Commented:
I just figured it out. Let's see if someone posts the right answer for the points!
0
 
Kamaraj SubramanianApplication Support AnalystCommented:
while doing ftp are you sure that you putting the file in correct directory ?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Maciej SsysadminCommented:
umask setting?
0
 
DrDamnitAuthor Commented:
umask setting.... where?
0
 
vikas_madhusudanaCommented:
in

/etc/indetd.conf

ftp stream tcp nowait root /usr/sbin/tcpd /usr/sbin/in.ftpd -u 007
0
 
DrDamnitAuthor Commented:
nope.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.