[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 261
  • Last Modified:

Restoring backup to SQL2008 from SQL2000. Read-only error

Hi,
I have successfully backed-up 5 databases from SQL2000 and restored them to our new SQL2008 server. However the last database (also the biggest one) wont restore as I get this error:

....."cannot be upgraded because it is read-only or has read-only files."

I have checked the permission of the backup file and also the destination folder on the new server. I cant find anything wrong. Im doing the exact same thing as all the other database which have restored perfectly.

Im using the enterprise manager on both servers to backup then restore.

Any ideas?


Cheers
Mitch
0
SM17CH
Asked:
SM17CH
  • 3
  • 2
1 Solution
 
Stephan_SchrandtCommented:
Check security permissions on the files + folder for the account sql server is running on (normally network service)
0
 
SM17CHAuthor Commented:
I double checked that. The files all have full rights granted to the admin account Im logged in as, plus SYSTEM and NETWORK SERVICE.
Also, I just tried detaching the DB, copying the files over to new server and attaching but I received the same error.
Any other ideas. Im struggling with this one.
Cheers
Mitch
0
 
SM17CHAuthor Commented:
ok, just to test I added 'Everyone' to the security tab with full permissions. Still the same error.
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
Stephan_SchrandtCommented:
You could use processmonitor to see if it really accesses the files and got a 'permission denied' or if the error message is the wrong one. Make use of the filter function to handle it:

http://technet.microsoft.com/de-de/sysinternals/bb896645.aspx
0
 
St3veMaxCommented:
Try this in tSQL:

RESTORE FILELISTONLY FROM DISK = 'C:\YourPath\YourFile.bak'

Note the VIRTUAL filenames and then

RESTORE DATABASE X
WITH
 MOVE 'datafile' TO 'C:\Pro~1\...\DatabaseName.mdf'
,MOVE 'logfile' TO 'C:\Pro~1\...\DatabaseName_Log.ldf'
,STATS = 1

replacing datafile and logfile with those from the 1st script.

If that fails, check things like available disk space.
0
 
SM17CHAuthor Commented:
I solved it.
Some of the database files where readonly. However they where readonly within the enterprise manager not in windows explorer which is how I missed it.
So I right clicked on the database in the source server. Properties. On one of the tabs i had a bunch of read only boxes ticked. I unticked. Detached copied to new server and attached again.
Thanks for all the help, sorry for the run around.
Cheers
Mitch
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now