[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1060
  • Last Modified:

Windows XP - Strange Connection Issues (ping but can't browse)

Appreciate ANY help I can get with this.

First, my laptop was working fine for the first 6 months. But I've had issues ever since and now, they are rediculous.

I have a BT Homhub which my desktop computer is connected to. This is NOT the issue. I recently upgraded to 6.2.6.H because of some incompatibility with my laptop's wireless card (2200BG).

Since then, the connection has stabilized but the main problem persists.

****

When I first turn my computer on, I can browse websites as normal. But after a couple of minutes, everything stops. My browser doesn't even try to resolve the addresses - it just refreshes immediately. Effectively I can't browse at all or connect to anything via other programs.

Strangely, I can ping but can't browse. I can ping google.com and that resolves the ip so I've been told it's probably not a DNS issue.

SOLUTIONS I'VE TRIED

*using a wired connection - same drill
the winsock fix
fixing ip stack
flushing dns
renewing ip
reinstalling wireless card
reinstalling tcp ip
reinstalling xp sp2
upgrading to xp sp3
manually setting ip and dns

Really, I've tried almost EVERYTHING. I have no idea what to do now but reinstall xp and hope that works. As you can imagine, I'd rather not do that.

Does anyone have any ideas what this might be or if they have encountered a similar issue in the past and fixed it?

Just to clarify:

can browse internet moments after computer switched on, soon after cannot browse any more yet can ping using cmd and domains are resolved to ip.

Any help is greatly appreciated.
0
DamienRoche
Asked:
DamienRoche
  • 10
  • 5
  • 3
  • +2
2 Solutions
 
ExcelGuideConsultantCommented:
so that means when you ping an http address and then copy/paste the IP into your browser, you would get connected to the website? If so, then you are having DNS problems for sure.

If you are using a router, I would definately test with another one or try to make the DNS static in your router (or even better, use another DNS...check your ISP provider).

I had this problem a couple of times and had to renew my router.
0
 
DamienRocheAuthor Commented:
Hi Psychotec - no, when I paste in the address I see in cmd after google has been successfully pinged - the browser does nothing. It refuses to even try it would seem.

I've tried this with

ie6+
ff2+
opera
safari
chrome

exactly same behavior. The browsers just refuse to even try resolve the domains or ip's.

How would I make the dns static in my router? BT Homehub?
0
 
ExcelGuideConsultantCommented:
do you still have the same problems when you connect your laptop directly to your modem, without the hub? If so, then contact your ISP...
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
DamienRocheAuthor Commented:
Not entirely sure. The hub is connected directly to the phone line. I don't have a modem.

..and it still does the same thing when I connect directly to the hub.

BUT I can't see how the hub is an issue because I have my desktop computer connected directly to it and I've never had an issue yet in over 3 years.

I just repaired the connection on laptop using the 'repair' dialogue and everything seems to be working again. But not for long, it just cuts of again yet can still ping and resolve ip's and even obtain details using nslookup google.com.
0
 
ExcelGuideConsultantCommented:
well...the only thing I can think of is your power options.....

you also can check the following website for more checks:
http://community.contractwebdevelopment.com/your-wireless-connection-dropping
0
 
DamienRocheAuthor Commented:
HI, thanks for you help Psychotec. I figured power options but I've set everything to stay on regardless of running on battery or mains. Still happens.

The indication light for my card never actually goes out and I've had the same problem when I wired the laptop to the hub, which obviously doesn't use the wireless card.

Thanks again, will check out that site.
0
 
Danny ChildIT ManagerCommented:
If you can try the laptop on someone else's wifi point, that will rule out software issues on your laptop.  I think this isn't a software issue though...  McDonalds and others do free WiFi in a lot of places.

I would think it is the ISP, or your Telco.  If you're on BT, they can do some line testing pretty quickly.

I would also try some Malware scans, but they're hard to do without being online.  
http://www-new.experts-exchange.com/articles/Software/Internet_Email/Anti-Virus/THINGS-YOU-NEED-TO-DO-WHEN-YOUR-PC-IS-INFECTED.html
0
 
Danny ChildIT ManagerCommented:
Ahhh, just seen that you've also got a PC working correctly on the same connection.  If that's fine, then it points more to Malware.   I'd also suggest getting it working on a wired connection first, just to avoid having to worry about interference, wireless security, etc till it's fixed.  I'd also clear the Internet Cache on the laptop too.  

Any event log errors of note?
0
 
idevilCommented:
try changing your DNS to open DNS which is 208.67.222.222 and use 208.67.220.220 as secondary DNS server and see how it goes.

How often you restart your HUB or main Modem. if you restart them, first turn the modem on and then turn the HUB/Router ON after 2 minutes. and see how it goes.

Also, could you create a new user account on your computer (presuming you are on XP) and then log in as that user and see if you lose the connection in same way you do in old account. If you don't then there is a possible corruption in your profile.
0
 
TekServerCommented:
I disagree with Dan's first point, and agree with the second.

First:  Given that there is a desktop computer attached to the same router, sharing the same ISP connection, and it's having no problems, it is EXTREMELY unlikely that the router or ISP are to blame.  But you can try the laptop on a free WiFi connection as suggested to confirm this (McDonalds, Whataburger, Starbucks, library, etc.).  If the problem follows the laptop (which it most likely will), then the ISP is not to blame.

Second:  Given all the troubleshooting you've already tried, and the fact that you haven't mentioned any malware scans, I think malware is the most likely culprit.  I'd recommend scanning first with Malwarebytes.  If at all possible, pull the hard drive from the laptop and attach it to your desktop, or another known clean machine, and scan it there.

hth
:)
0
 
TekServerCommented:
I should know by now to refresh before posting ...

:\
0
 
DamienRocheAuthor Commented:
Right, I'll add these to the solutions I've tried:

=====================

creating a new user account and logging in with that
scanning for malware
using a different connection (tried wireless dongle at my Dad's on 3G) - same issue
changing dns to 'open' settings detailed above

=====================

I use malwarebytes frequently and I haven't turned anything up on my laptop. However, this current installation of xp HAS had a virus attack it before. So possibly could be malware. I may just reinstall xp or get windows 7.

**repairing the connection using xp repair function when viewing wireless network DOES work temporarily. But then same drill as before, just stops working.

..Which obviously means clearing the dns and/or renewing ip is doing something. But only temporarily.

Thanks for all your help so far! Hope somebody has had this issue before and knows what the hell is going on.
0
 
TekServerCommented:
Just out of curiosity, can you browse if you boot into "Safe Mode with Networking"?
If so, the problem may be associated with some startup program.

:)
0
 
DamienRocheAuthor Commented:
Hi TekServer, tried that but same behavior.

I keep a very close eye on my startup processes. I actually only have 4 startup processes.

I really am stumped. I just don't understand how all of this STILL hasn't even touched on a solution.

Open to any other suggestions. Hopefully I won't have to reinstall xp.
0
 
TekServerCommented:
We may not have touched on a solution yet, but we are narrowing things down.
 
 Okay, a couple more things we can try.  First, let's get a HijackThis log so we can see if there's anything weird in there.
 
 Once you've got that (let us know if you need assistance with that, but I suspect you're familiar with HJT), reboot your machine, then time, as accurately as possible, how long it takes before you lose the ability to browse.  Once you've got that time recorded, check the event logs (especially Application and System Logs) for any events out of the ordinary, especially around the precise time you lose browsing functionality.
 
 Please post your HJT log, and anything interesting you find in the event logs, and we'll go from there!
 
 :)
0
 
DamienRocheAuthor Commented:
Interesting. I just checked the event viewer - here is what I have:

the browser has forced an election on network \device\netbt_tcpip_{REGSTRING} because a master browser was stopped.

the regstring being some long code like 743247DJD-3423-DJKH0-4321

Does that give you any other ideas?

I will look at that HJT log.

Thanks again.
0
 
DamienRocheAuthor Commented:
Sorry, think you can ignore that. I think that was when I repaired the connection disabling the wireless card and re-enabling.

One thing, this time - I went to google after repairing connection. that worked fine, then I opened a new tab and it wouldn't load anything. not even google again and it wouldn't reconnect on the original tab I opened with google (by refreshing page).

The bahvior in firefox at least is that it doesn't even try to connect. As if it is in offline mode or a port is blocked or something. In ie it just refreshes but can't connect.
0
 
DamienRocheAuthor Commented:
Something else which might help.

Say I create a new tab and put in yahoo.com in the browser. When I press enter if it's not working it will just stay the same. Nothing happens. But say I try again about 10-20 times, one of those times it WILL work. of course the page it loads isn't fully loaded.

Another example...if I click a link to a website when it's no working, it will obviously stay on the same page and not load anything. BUT, if I keep clicking that link - again, 10-20 times, it WILL eventually go through the link and load the page.

Any ideas? does that shed any light on what could be happening?
0
 
DamienRocheAuthor Commented:
I DO BELIEVE IT'S FIXED!

Probably the major reason none of the above worked was because this wasn't a problem caused by normal networking issues. I had a worm which was intercepting my connection.

it was:

unwise.exe usually found:

c:\windows\Fonts\unwise.exe

I ran gmer which found the hidden process and identified it as a virus. I then ran combofix to clean the comp up. Ever since even disabling the service, everything worked fine immediately, and now after the cleanup, everything is working perfectly permenently.

Thank you all for you help! I really appreciate it.

Hope this can help somebody else in a similar situation. If in doubt, scan with malwarebytes AND gmer AND combofix.

0
 
DamienRocheAuthor Commented:
Solution was that I had a virus.
0
 
Danny ChildIT ManagerCommented:
interesting issue... but no points for me?  I was the first to suggest malware scans!  grrrrrr   ;-]
0
 
TekServerCommented:
Thanks!  Glad I could help.

(Though I wouldn't have objected to Dan getting a fair share of the points ... )

;)
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 10
  • 5
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now