?
Solved

OWA "Internet Explorer cannot display the webpage" after login

Posted on 2010-01-07
19
Medium Priority
?
2,423 Views
Last Modified: 2012-05-11
Hi Experts,

Exchange 2003 on Server 2003

OWA has been working fine for more than 2 years but all of a sudden I get the "Internet Explorer cannot display the webpage" error page after a correct login.

I have recreated the virtual directories to mo avail.

FF gives a bit more information. It reports "Firefox can't find the server at trade.XXX.co.uk" but the server that is handling the OWA is called DC1.XXX.co.uk. Again this only happens after the login box is completed with a valid login.

So it appears after a valid login on DC1.XXX.co.uk I am being redirected to trade.XXX.co.uk. This server does not have a DNS record so i get the error. But why is OWA redirecting me here? trade is a stand alone server on a different IP subnet that has nothing to do with exchange!

Any help is appreciated.
0
Comment
Question by:paulm987
  • 8
  • 6
  • 3
  • +2
19 Comments
 
LVL 27

Expert Comment

by:shauncroucher
ID: 26200109
Check your port forwarding for 80 and 443 (are you using SSL). Make sure the protocol is being directed to the Exchange server.

Does this happen if you try to access locally on the server itself? ie: https://localhost/exchange

Shaun
0
 
LVL 3

Expert Comment

by:tusharnextgen
ID: 26200203
0
 

Author Comment

by:paulm987
ID: 26200368
Thanks for the quick replies.

tusharnextgen:
IE is working fine in all other respects, it's just the exchange OWA I'm having problems with.

shauncroucher:
I'm not using SSL and I have the default website using port 9001 as port 80 was already in use.

The behaviour I described earlier were from browsers run on the server (I can resolve the FQDN internally to it's internal address).

If I logon as a mail enabled user and go to http://localhost:9001/exchange I get a split screen with the message Internet Explorer cannot display the webpage in both panes.

FF still redirects after login to the other server!!
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 27

Expert Comment

by:shauncroucher
ID: 26200444
Sounds like it could be an issue with security on the virtual directories.

Check that you don't have SSL enabled on any virtual directories

Check here: http://www.msexchange.org/tutorials/Resetting-OWA-Folder-IIS-security-permissions-Exchange-2003.html

and here: http://www.msexchange.org/tutorials/Fixing-Damaged-Incorrectly-Configured-OWA-2003-Installation.html

Shaun
0
 

Author Comment

by:paulm987
ID: 26200717
Hi Shaun

I've had a look at those articles and recreated the Virtual Directories already, still busted I'm afraid!

I think the clue is FF trying to link to another server but I'm not sure where this server name is setup.
0
 

Author Comment

by:paulm987
ID: 26200724
Sorry, I checked SSL and none of the VDs have SSL required
0
 
LVL 27

Expert Comment

by:shauncroucher
ID: 26200755
0
 

Author Comment

by:paulm987
ID: 26201586
Shaun

All looks OK.
what does \\.\BackOfficeStorage\XXX.co.uk\MBX resolve to?

Regards
Paul
0
 
LVL 27

Expert Comment

by:shauncroucher
ID: 26201791
That can be expected. It's system set.

I'm out of ideas at the moment, I' might run the Exchange Best Practices Analyser on this Exchange server and see if it provides any more info,

Also see if an update may have removed the port 9001 from the IIS config at all?

Shaun
0
 

Author Comment

by:paulm987
ID: 26202009
Thanks Shaun,

I'll run the BPA and see what that comes up with.

Off home now and not in tomorrow so it'll be the weekend or Monday be fore i post next.

Thanks again.
0
 
LVL 27

Expert Comment

by:shauncroucher
ID: 26202312
No problem

Shaun
0
 
LVL 20

Expert Comment

by:Satya Pathak
ID: 26203367
Please find IIS authentication type and the SSL requirement for Exchange 2003.
1) Default Website : Annonymous & Integrated     NO SSL
2) Exadmin : Integrated                                    NO SSL
3) Exchweb : Annonymous                              NO SSL
4) Exchange: Basic                                        SSL Optional
5) RPC     : Basic                                        SSL Required
6) OMA     : Basic                                       SSL Optional
7) Public  : Basic+Integrated                         SSL Optional
8) exchange-oma : Basic & Integrated             NO SSL
9) Microsoft-Server-ActiveSync : Basic           SSL Optional
After that need to restart IIS service and check it.
0
 

Expert Comment

by:cfitech
ID: 26310135
Could it be a Microsoft Update. I have a client who is experiencing the exact same problem that started about 1 week ago. paulm987 did you ever figure this out? Thanks.
0
 

Expert Comment

by:cfitech
ID: 26310403
I am not sure if I am onto something or not, but......

If I goto http://domain.com/exchange it asks me to login and then I get the same error: "Internet Explorer cannot display the webpage"

However, If I then goto http://domain.com/oma it asks me to login again and then gives me an error: "A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator."

I then go back to the http://domain.com/exchange and refresh the page and my OWA works???

Does this spark any ideas?
0
 

Author Comment

by:paulm987
ID: 26312391
I'm still at a loss here!

Run BPA - nothing of any import, a few memory settings to change
Check the IIS authentication - all as should be
Tried connecting to OMA - Just get the Internet Explorer cannot display the webpage eror

Any mjore ideas, I'm close to cashing in an incident from my TechNet subscription!
0
 
LVL 27

Assisted Solution

by:shauncroucher
shauncroucher earned 800 total points
ID: 26312434
Have you tried to recreate all the virtual direcories, because if you have it might then be time to speak with Microsoft on this one.

Shaun
0
 

Author Comment

by:paulm987
ID: 26312445
Hi Shaun,

Yes been through the delete and recreate documentation, still no joy.

I'll be onto Microsoft this afternoon and let you know what happens.

Thanks fo the help.
0
 

Assisted Solution

by:cfitech
cfitech earned 400 total points
ID: 26313355
I posted my issue seperately and the following procedure solved my problem. Mainly the "in the exchange and OMA directory in the IIS only select "basic authentication"." section since that was the only thing that differed on my server. Everything else already matched. I removed the Integrated Windows Authentication for Exchange and OMA and now I can login. I also around the same time logged in with domain\user and password and that is when I saw it work first. But everytime I try it now with or without the domain\ as part of the user it works. Hope this helps.

Exceprt from my other post:

you have to uncheck the "anonymous access" from all exchange feature : OWA, OMA and RPC in the IIS.

then you have to create the exchange-oma directory in the IIS and in "authenticated access" select "integrated windows authentication" and "basic authentication". in the default domain type ( \ ) without bracket.

in the exchange and OMA directory in the IIS only select "basic authentication".

then you have to uncheck the option "require secure channel SSL" from the exchange-oma and OMA directory in IIS.

also, you have to know that may be my IIS directory name is not the same as your IIS. but they all mean the same thing
0
 

Accepted Solution

by:
paulm987 earned 0 total points
ID: 26321909
Sorted at last and I didn't have to ring Microsoft!

The system had the SetHostName metabase property set to a FQDN that was not accessable.

I reset this property to the correct address and hey-presto normal service was resumed.

Microsoft KB 834141 gives info on fixing this.

Thanks for your help Shaun and CFITech.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this post, I will showcase the steps for how to create groups in Office 365. Office 365 groups allow for ease of flexibility and collaboration between staff members.
Mailbox Corruption is a nightmare every Exchange DBA wishes he never has. Recovering from it can be super-hectic if not entirely futile. And though techniques like the New-MailboxRepairRequest cmdlet have been designed to help with fixing minor corr…
This video discusses moving either the default database or any database to a new volume.
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Suggested Courses
Course of the Month16 days, 19 hours left to enroll

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question