Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5210
  • Last Modified:

Cannot Publish InfoPath form to SharePoint Form Library - Updating the Content Type Failed

I created a form and for whatever reason, I cannot get it to publish to the SharePoint Form I created for it through the InfoPath Publishing Wizard.  I don't have a whole lot of experience with InfoPath, but then again, this is not the first InfoPath form I created - I've created a couple of other forms and form libraries and I never ran into the sort of trouble I am experiencing with this particular form when I try to publish it.

It appears that some of the information is being published to the library - for instance, when I look at the library's settings, the data fields have generated the columns.  However, these columns did not appear to be generated when looking at the "All Documents" view in the form library itself.  Furthermore, the form itself does not publish to the library.  Every time I try I get the "Updating the content type failed" error message (see image).

I've compared the settings configured in this form to other successful forms I created that are working with the a SharePoint Form Library, but I haven't seen any differences.  I also have full control permissions on the site and library I am trying to publish to form to.
infopath-content-type-fail.JPG
0
mylogo
Asked:
mylogo
  • 3
  • 3
1 Solution
 
janicet123Commented:
I just had this problem not too long ago and this method of publishing helped since we were republishing to a form library. I believe if this is a new form, you can also try this by creating the columns in the library before you publish and then using the method below to link them.
http://acuffgroup.com/2009/01/21/tip-for-publishing-infopath-form-to-sharepoint-library/ 
0
 
mylogoAuthor Commented:
I tried the method as suggested from the link above, but I cannot get past the 5th screen on the Publishing Wizard.  

During the process in the Publishing Wizard, I choose "This document library" under the Site Column Group and then add one of the columns names listed - however, when I click on OK, I get another error message that says, "Non-repeating groups are not supported as document library column names."  I've tried just about all of the columns listed and I get the same result.  Therefore, I cannot reach the  
not-supported.JPG
0
 
janicet123Commented:
Hmmm. Is the column you are trying to promote bound to multiple controls? Is this a browser form or a regular form?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
mylogoAuthor Commented:
I have it set to enable from a browser, but also want it available as a regular form.  However, I've tried publishing it both ways and it does not seem to matter - I get the same error either way.
0
 
mylogoAuthor Commented:
I removed all of the field columns and I was then able to publish the form.  Then I went back in and tried  adding the columns back in, using the Site column group option of "Create new column in this library" (as I had done originally) and for some reason it decided to publish everything as it should have to the library.  I've now gone back in several times and I am able to publish the form to the library every time without any problems.  

I don't know why that worked - but it did - so problem resolved for the time being.
0
 
janicet123Commented:
LOL - Aren't intermittent problems fun? :-) Please post back if you find anything more or if it happens again. Good luck!
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now