[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Citrix java application not working on my mac

Posted on 2010-01-07
5
Medium Priority
?
1,251 Views
Last Modified: 2013-11-23
Clever bods please help,
my company uses a citrix access gateway to give employees access to remote desktops. I work on a mac and these are just not helpful combinations.

Anyway, after months of having no access at all, I was advised to download latest citrix access gateway for the mac from citrix and try it. And it worked! Fantastic so far ...

Everything works in terms of the connection ... right up until I go to load a java app when I just get the Java window with a blue 'X' in the top left corner. There also seems to be an issue with the certificate not being recognised (but it is the latest version).

Any help you can give me would be ENORMOUSLY appreciated (be gentle though, I'm a designer not an IT whizz) ... especially as I'm trying to log on to work whilst snowed in!

Thanks,
Steven
0
Comment
Question by:stevenradams
  • 2
  • 2
4 Comments
 

Author Comment

by:stevenradams
ID: 26202341
OK ... some progress. The problem isn't the certificate, it's the launch.ica (I think). I've done a lot of searching on citrix and seemingly the problem is something to do with secure settings not allowing the launch file to be saved.

I can get further in parallels (64-bit Vista with correct citrix secure access gateway client) where i get prompted to save the launch.ica file when clicking on the java app, but no amount of loosening my internet options seems to help (including saving encrypted pages etc).

Please help... :/
0
 
LVL 11

Expert Comment

by:nordtorp
ID: 26204248
I am not sure what you have downloaded and installed, but is it this:

Citrix Online Plug-in for Mac - Version 11.0
http://www.citrix.com/English/SS/downloads/details.asp?downloadId=1856482&productId=186&c1=sot2755&c2=ost12726

If not, try to install it and give it a try. Remember to close all web browser windows first.
0
 
LVL 11

Expert Comment

by:nordtorp
ID: 26204267
You might also check that the settings in the web access is set to Local Client and not Java Client.

After you have logged in there should be a button for settings, click that and go to Preferences.
0
 

Accepted Solution

by:
stevenradams earned 0 total points
ID: 26207829
Thanks for this ... it's been solved by via the long route. The mac client (which was the one you linked to) still doesn't work but the windows client eventually worked once I'd downloaded an additional metaframe plug in (whatever that is).... no indication it was needed initially but I just loosened all my Internet ActiveX settings and then downloaded every 64-bit plug I cd see, tearing each step o the way. Eventually it worked!

I think this is the brute force method...!
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If your vDisk VHD file gets deleted from the image store accidentally or on purpose, you won't be able to remove the vDisk from the PVS console. There is a known workaround that is solid.
Article by: Justin
In light of the WannaCry ransomware attack that affected millions of Windows machines, you might wonder if your Mac needs protecting. Yes, it does and here is how to do it.
This tutorial covers a practical example of lazy loading technique and early loading technique in a Singleton Design Pattern.
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…
Suggested Courses
Course of the Month19 days, 14 hours left to enroll

873 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question