• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1000
  • Last Modified:

internet explorer 7 certificate error for Trusted Verisign Cert

I have a trusted Verisign cert but when people access the https webpage they still get the untrusted error prompt. How is this possible ?




I have also studied http://www.experts-exchange.com/Web/Browser_Issues/Q_22084818.html but this is a self signed cert not a trusted CA as mine...
0
JAaron Anderson
Asked:
JAaron Anderson
  • 6
  • 3
1 Solution
 
Ravi AgrawalCommented:
Have you checked the date on the machine. Is it set to correct. A bad date will trigger a good cert as bad.

Ravi.
0
 
JAaron AndersonProgramming Architect @ Widener UniversityAuthor Commented:
yes checked the date/time of the laptop its XP IE8 right date/time...
0
 
JAaron AndersonProgramming Architect @ Widener UniversityAuthor Commented:
its weird sometimes when the guy on his laptop at work it works and when hes on other networks it does not and prompts him... any ideas ?
0
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

 
JAaron AndersonProgramming Architect @ Widener UniversityAuthor Commented:
could it be the bit depth of the cert is conflicting with a browser experience of a lower or higher bit based computer ?
0
 
Ravi AgrawalCommented:
IE7 is 128bit, so I don't think the problem is there. The 32-bit / 64-bit computer architectures should not make any difference.

Check out Internet Options under Control Panel. Switch to the Advanced Tab & see if the following are checked--

Use SSL 3.0
Use TLS 1.0

See if the issue persists.

If no luck, open it again and hit  the "Reset" button. This will reset it to system defaults and clear all clutter in IE disabling all Add-ons.

Now check.

Ravi.

IE-options.PNG
0
 
JAaron AndersonProgramming Architect @ Widener UniversityAuthor Commented:
I had the client who complained of the issue check these options and enable them and also download the latest optional CA digest from windows updates. so this wasnt it  ... hmm what next?
0
 
Ravi AgrawalCommented:
http://support.microsoft.com/kb/902932

Try re-registering dlls of IE.

Ravi.
0
 
JAaron AndersonProgramming Architect @ Widener UniversityAuthor Commented:
ok Ill try that
0
 
JAaron AndersonProgramming Architect @ Widener UniversityAuthor Commented:
Yeah we had been trying everything and we believe it is because we had a HOST Record for the Server Common Name which the cert is assigned for in our DNS Server and NOT a physical  "A" Record entry.

although host records mimic the functionality of A and CNames, and typically perform their duties accordingly, they evidently get sticky and combative when dealing with certs if/when ONLY a hostrecord has entries in DNS.

In all, it was a good "hard-earned" learning thanks to Panaormatic & Rovastar for their provoking input to flush out what the solution was by process of elimination. :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

  • 6
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now