Need to fix compatability issue with windows 7 64 bit for vfp version 7 (and 8 and 9)

Can someone tell me how to fix this issue? I don't know where to set the compatability here. Quite a few apps I run need to shell out to do their jobs.

---------------------------
Unsupported 16-Bit Application
---------------------------
The program or feature "\??\c:\program files (x86)\microsoft visual foxpro 7\foxrun.pif" cannot start or run due to incompatibity with 64-bit versions of Windows. Please contact the software vendor to ask if a 64-bit Windows compatible version is available.


---------------------------
OK  
---------------------------
busycoderAsked:
Who is Participating?
 
pcelbaConnect With a Mentor Commented:
Foxrun.PIF really not supported in 64 bit environment. But it is probably not needed even in 32 bit environment... VFP9 moved this file to Tools\FoxRun\ subfolder.

So, rename foxrun.pif to foxrun.pif.old and try again.
0
 
busycoderAuthor Commented:
That was it I like an easy answer!!!!! Thank You!!!!!!
0
 
busycoderAuthor Commented:
Nice quick work! Thanks!
0
 
pcelbaCommented:
You are welcome!

It seems I should install some 64 bit OS... :-)
0
 
busycoderAuthor Commented:
Only if you want exercises in aggravation, with no noticeable speed benefits IMHO. :)

Thanks again for the quick answer and fix. I am back to the ease of XP where this is concerned.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.