ora-01031 error during install of oracle 11g on windows 7

Posted on 2010-01-07
Last Modified: 2013-11-11
I'm a college student and am forced to try and install oracle on windows 7 pro (knowing full well it isn't supported by windows 7 yet).  After 10 hours I'm...frustrated.  

I assumed oracle 11gR1 x64 was my best chance of success.

i can (finally) get as far as the Oracle Database Configuration Assistant when it errors out:

ora-01031 insufficient privileges.

if i hit ignore, then ignore again, ora-01034: oracle not available appears

hittting ignore 3x generates
ora-01034: oracle not available
ora-27101: shared memory realm does not exist

hitting ignore again generates:
ora-01503 create controlfile failed
ora-01565 error in identifying file c\:oracle11g\oradata\orcl\system01.dbf
ora-27041 unable to open file

I am logged into Windows 7 as an admin.

I have tried right clicking the command prompt and selecting "as administrator" and tried executing the setup.exe file from there -- it fails.

I have installed the loopback adapter and used in the hosts file: [my computer host name] [my computer host name]

I have modified the refhost.xml file:

<!--Microsoft Windows 7-->

i have googled ora-01031 and all the other errors and the few solutions i've found are abbreviated expert opinions that assume a level of knowledge way beyond my own.
a step by step process / solution would be awesome.

any help would definitely be appreciated!

Question by:dvcrdu
    LVL 6

    Accepted Solution

    Few day ago I have installed Oracle for  Microsoft Windows Server 2008 x64 on my Windows 7 64 bit without any problems - that is the only untypical thing to do is to force installer to ignore failed pre installation check - which says that this version of OS is unsupported - you are doing it by clicking appropriate checkbox near failed check message at the first stage of installation.

    I did not try to install version (which I suspect you are installing) on Windows 7 so I can't say if your error is common or not.

    I recommend to try to install Oracle 11gR1 for Windows 2008 Server 64 bit.

    Author Comment

    thanks, arturrrro, i'll try it and see what happens.

    Author Comment

    it worked like a charm.

    Thank you very much!


    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Join & Write a Comment

    Note: this article covers simple compression. Oracle introduced in version 11g release 2 a new feature called Advanced Compression which is not covered here. General principle of Oracle compression Oracle compression is a way of reducing the d…
    Checking the Alert Log in AWS RDS Oracle can be a pain through their user interface.  I made a script to download the Alert Log, look for errors, and email me the trace files.  In this article I'll describe what I did and share my script.
    This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.
    The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

    745 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now