Cisco SMTP application inspection modifies Exchange traffic: why?

I get an error sending mail to Hotmail-based servers from my Exchange 2007 (SBS 2008) server only when SMTP application inspection is enabled on my Cisco 881W router. Mail sent to other domains (eg. Gmail, Yahoo, etc) accept with no problem. Hotmail returns "#500 Unrecognized command ##"

If SMTP application inspection is disabled, mail is delivered immediately to Hotmail with no problems.

Can someone clarify *why* this is an issue. It is my understanding that "inspection" should imply that no modification is taking place.

Thanks for any help, I'm really confused by this..
Chief_ArchitectAsked:
Who is Participating?
 
Chief_ArchitectAuthor Commented:
I solved this before *posting* the question. I just wanted to know if someone else could verify that there is indeed a bug in Cisco's IOS that causes SMTP application inspection to corrupt outgoing packets which is the behavior I believe I'm seeing, or else explain to me why inspection modifies packets if it's not a bug.

Right now, the *only* way to solve the issue is to disable SMTP application inspection.

I expect to eventually hear back from the Cisco technicians I've contacted about this problem that it is a bug and may be fixed in a future IOS version.
0
 
Chief_ArchitectAuthor Commented:
I forgot to mention this appears to be a known issue as evidenced here: http://social.technet.microsoft.com/Forums/en/exchangesvrtransport/thread/2f166392-315f-44b4-914d-24686f15c708
0
 
memo_tntCommented:
hi

you are answering your self

you need to disable SMTP packet inspection or you'll see some serious mail delays/failures as you face now with hotmail. check Cisco's article here:


http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a00800941c8.shtml

http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a008067cf3b.shtml
0
Increase Security & Decrease Risk with NSPM Tools

Analyst firm, Enterprise Management Associates (EMA) reveals significant benefits to enterprises when using Network Security Policy Management (NSPM) solutions, while organizations without, experienced issues including non standard security policies and failed cloud migrations

 
Chief_ArchitectAuthor Commented:
Thank you for the quick response. I'm trying to understand why this is an issue with a pretty new router (Cisco 881W wireless router) running the latest IOS release (15.0).

What I'm looking for is an explanation of why this is a problem in the first place. ESMTP has been around for a long time. Is Cisco not sticking to protocol correctly? Is this because Microsoft's Exchange server violates protocol?

Also, the links you mention only refer to PIX firewalls, which I don't have. Do they behave the same way?
0
 
memo_tntCommented:
yes it's the same behavior as cisco mentioned that , hence it's a firewall issue same like other devices ..


0
 
memo_tntCommented:
Hi
 
 please update status regarding this issue ..
 
 is it solved ??
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.