Network troubles

Posted on 2010-01-07
Last Modified: 2013-11-12
I have an issue that's been stumping me for a few days. This will take a bit to explain...

A client asked me to reconfigure their network. They have 5 PCs that connect wirelessly to an old D-Link router (4-WinXP Pro, 1 Win2000). One of the WinXP PCs acts as their Quickbooks host machine. Another one of the WinXP PCs connects to the QB database in multi-user mode to process items.

They also have a lobby with 2 Win98SE (ugh) PCs connected (wired) to the router for clients to use as they wait for their cars (it's a garage).

I recommended that they move to a network with VLANs (one for clients, one for corporate), or at very least they buy a router that supports multiple SSIDs that can be isolated from each other.

They agreed to the first option, so I purchased the Cisco WRVS4400N which has a built-in L2 switch and supports VLANs. I configure the router and plug it in. None of the current wireless systems were able to connect ... which is fine because they wanted to upgrade to 'N' adapters anyway. Meanwhile I plug back in the old router which promptly dies and won't power on ... a sign of woe to come. They have purchased D-Link DWA-130 USB adapters which seem to connect with no issues to the new Router.

The Win98 machines are plugged in to Ports 3 and 4 of the Cisco on their own VLAN and are also working.

Then we try to connect Quickbooks from the client machine to the host machine. The host machine promptly drops all network connectivity, as does the client machine. I eventually decide to rebuild the host machine for them as it had all sorts of useless config (Novell protocols, IPV6, registry cleaners installed, tons of junk, etc.) and was super slow. The problem seems better initially, but then does the same thing ... keeps dropping the wireless connection when the client machine tries to connect. Sometimes it will connect for a few seconds, and sometimes for a couple of hours ... but the connection eventually just drops.

I figure that the router might be flaky, so I install a spare D-Link DIR-825 which can support 'Guest SSIDs' ... not as good, but good enough to test if it's a router issue. The same problem exists with this router too.

I then put the Quickbooks host PC on a wired port and try to connect from the client (still connected wirelessly). Connection drops. The I try both the client and host PCs on wired ports of the DIR-825, and have no issues at all. So, what are we left with? It's either a wireless issue on both routers, or possibly the wireless NICs? Is Quickbooks the problem?

The building has almost no physical cabling, but there is actually a wired link from the office with the QB client to the office with the QB host. As a work around, I'm using the Cisco router in "Router" mode to connect those PCs together on a 192.168.1.x network. I've left the wireless connections active (on 192.168.0.x) connected to the D-Link, but I can't get both networks to work at the same time ... as a stop gap, is this possible to get working? ... to let these PCs use Quickbooks over the wired connection (cisco), and still have internet access through the DIR-825 wireless?

The other PCs seem to be working fine just connecting wirelessly to the DIR-825.

What would you test next to find the source of the issue?

I read one experts-exchange solution that mentioned a similar issue that went away when they configured the wireless NICs with static IPs. I tried this too, but the issue remains.

Routers and NICs were updated to the latest firmware/drivers. I've tried using the DLink NIC s/w as well as the built-in wireless manager in WinXP, and have the same results.

Thanks in advance,
Question by:IT_Service
    LVL 57

    Expert Comment

    What is providing the DHCP server function?

    Is it properly setup to provide two separate DHCP scopes to 2 different VLANs?
    LVL 2

    Author Comment

    When I had the Cisco router configured with VLANs, yes I had a 192.168.1.x scope, and a 192.168.2.x scope configured. That part was working.

    For now there are no VLANs. The DLink is set with 192.168.0.x scope, and the Cisco (in between the 2 Quickbooks PCs) is set with a 192.168.1.x scope ... although I'm using static IPs for the PCs now, but each PC cannot seem to connect to both networks at the same time.

    Is this possible to do?

    LVL 57

    Expert Comment

    Some of the Cisco/Linksys devices have firewall rules, or ACL type firewall rules, enabled by default.  Could something like that have been enabled that prevented routing between the two IP Subnets?

    I need to read up on the WRVS4400N.
    LVL 2

    Accepted Solution

    i'm going to close this question and break it down into a couple separate questions.

    i've managed to duplicate the original issue on a separate network ... where the wireless connection drops trying to use quickbooks. i have no idea how they were able to run like this in the first place on their old dlink router, but that's what they claim.

    the second issue could probably just be solved by using an access point that includes a wired switch ... although I'll repost the question as I'm not totally sure.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Do You Know the 4 Main Threat Actor Types?

    Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

    In this article we have discussed about the OS X EI Capitan and how to fix Wi-Fi issue in OS X El Capitan. We have explained how to delete system level preferences and create a new Wi-Fi location to resolve Wi-Fi issue.
    This is an article about my experiences with remote access to my clients (so that I may serve them) and eventually to my home office system via Radmin Remote Control. I have been using remote access for over 10 years and have been improving my metho…
    Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
    This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…

    761 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    8 Experts available now in Live!

    Get 1:1 Help Now