• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4720
  • Last Modified:

How to FTP Axis Camera to ReadyNas

I have a Axis Ip camera (M1031-W) and a Netgear ReadyNas Duo. I have been trying to get the Axis Cam to upload files to the ReadyNas with no luck. I can reach the NAS sing "Fetch" and firefox but the camera says the file does not exist-See attached error message. I contacted Axis Support and they state:

Dear Kevin Young,

You unfortunately cannot just have a camera, through the web interface, point towards a drive like a NAS drive without having a FTP set up pointing at that driving which requires using IIS.

You can use that NAS drive using a software called Axis Camera Station One. Which is a complimentary software but unfortunately does not have any technical support.

You can download this software using this link http://www.axis.com/techsup/cam_servers/cam_station_software/firmware.php

Best regards,
Axis Customer Services

I Am hoping someone on this site has had success setting up FTP on this camera to a ReadyNas.
Server-Error-msg.jpg
0
poucedeleon
Asked:
poucedeleon
  • 5
  • 4
1 Solution
 
James MurrellProduct SpecialistCommented:
as they said you need to get Axis Camera Station One and the you can ftp
0
 
kode99Commented:
Have you setup a Event Server then setup a Event Type do direct images and/or clips to the FTP server?

This allows you to configure the camera to send to a server on motion detection schedules or just continuously.

Here's a link to the manual,  look under 'Event Configuration',

http://www.axis.com/files/manuals/um_m1011_m1031_34147_0812.pdf

There may be some limits with this particular model,  you may not be able to take advantage of H264 and be limited to sending a sequence of jpg's to the server.

If you have followed the steps here and it's not working let me know what settings you are using and we can likely figure out the issue.

There are a few NAS units on the market that provide a full web interface for working with a number of IP camera's.  Here's a couple of links,

http://www.qnap.com/Products2.asp

http://www.synology.com/us/solutions/surveillance/index.php

These NAS or NVR style units can actually be more functional and less expensive than an equivalent software only package.
0
 
poucedeleonAuthor Commented:
I have set up the Event Server, I have attached a screenshot of my settings, also I included a link from ReadyNas Forum were a guy shows the process of setting up a IP camera. I followed it step by step, but I still get a error message.
http://www.readynas.com/forum/viewtopic.php?f=24&t=35490 
Services.jpg
ShareList.jpg
EventSettings.jpg
EventType.jpg
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
kode99Commented:
I suspect the problem is with the Upload path,  you do not need the IP address there only the path name.  When the camera sends pictures it will send relative to the servers settings. If you clear the upload path on the camera settings and see where it puts the file.  You may just want the upload path set to /video or video in order to have the files sent to /Axiscam/video.

Right now the camera is probably trying to upload to 10.0.1.210/Axiscam/10.0.1.210/Axiscam/video which will be a invalid directory and get bounced with the 550 error.
0
 
poucedeleonAuthor Commented:
I changed the upload path as you suggest, but still get a error message
newerrorj.jpg
0
 
kode99Commented:
Try checking passive mode on the camera Event Server settings.

When you setup the 'Event Server' did you test it from the setup screen?  Is that where the error is showing.  Or is the error when the camera is trying to actually  send images?

I assume you are able to copy a file to the NAS with your ftp client without issue.

Maybe check in System Options and see what shows in the system log,  it may provide more detail about what it going on.

The other thing I noticed (which is not on my older Axis units) is the 'Stream Profile' setting in the 'Event Type' setup.  You have not set anything,  it may need this to be set.  If the test button fails this may not have come up yet but it may be needed later.
0
 
poucedeleonAuthor Commented:
I have tested from he server setup screen. That is where the error message is coming from. I tryed passive mode, but still received the same message or a timed out error message. I add the Stream Profile, but that didi not make a difference. Without the profile selected it still should have uploaded still images. I have been trying to get this to work since I bought this NAS last April, I am about ready to give up on Netgear and buy a Synology DS409
0
 
kode99Commented:
Something else I noticed in the ReadyNAS manual was that if it is set in 'share mode' security that it requires an email address as the password for a anonymous logins.  I also believe you need to actually use 'anonymous' as the username.  I am thinking that from the quotes used around anonymous in the manual.

Page 2-11 in the NAS manual,
ftp://downloads.netgear.com/files/ReadyNAS_UM_02Apr08.pdf

Possibly the PC client sends this by default but the camera does not.

0
 
poucedeleonAuthor Commented:
I had a computer crash and had to replace my computer. I have given up on this combo. I am going to replace my Netgear stuff, with a different brand. Kode99 I want to thank you for the effort you made trying to help me.
0
 
poucedeleonAuthor Commented:
We were not able to get this fixed, but it as not for the effort that kode99 put forth. Great work Great Help and lot of patience.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now