Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 678
  • Last Modified:

JDK 1.5 on Solaris 7 issue.

We are trying to configure WebLogic 9.2 on Sun Solaris 7 Operating System. We have installed WebLogic 9 successfully but facing following error message on startup,

<Server subsystem failed. Reason: java.lang.UnsatisfiedLinkError: /data/jdk-1_5_0_04/jdk1.5.0_04/jre/lib/sparc/libnio.so: ld.so.1: /data/jdk-1_5_0_04/jdk1.5.0_04/bin/java: fatal: librt.so.1: version `SUNW_1.2' not found (required by file /data/jdk-1_5_0_04/jdk1.5.0_04/jre/lib/sparc/libnio.so)

according to the information available on various Sun forums and jdk 1.5 help, we found that JDK 1.5 is not compatible with Sun Solaris version 7.

Is there any way out to get this working, i.e. JSK 1.5 on Solaris 7, as otherwise we will have to replace existing Solaris version 7 with 8 or 9 or10. This would be big task and client might not be happy to replace whole operating system on server just to get WebLogic 9 working.

Is there any way out to this solution? we need to get WebLogic 9.2 working on Solaris 7.
0
techprocess
Asked:
techprocess
1 Solution
 
RajeshpolaCommented:
SInce u said that for u r issue OS upgrade it not a fesible solution, just try to resolve the issue one after the other. Since it is soalris 7 , why cant you go for Weblogic 8 than weblogic 9. Ofcouse both of these versions are not supported by Oracle now.
0
 
techprocessAuthor Commented:
The reason we are not going for WebLogic 8 is it is no more supported by Oracle, for WebLogic 9.2 it is still supported by Oracle, till Nov 2013.

Also we tried to address the issues one after the other,
1. we tried to use lower JDK version i.e. jdk 1.4 but it didn't worked for WebLogic 9.2
2. we are searching for any solaris 7 updates for JDK 1.5 support but didn't found any

are there any solaris package updated for JDK 1.5 support? or there is only way out of using higher solaris version than 7 for WebLogic 9.2?
0
 
softwarepearls_comCommented:
What is your exact dependency on WebLogic 9.2? Sometimes teams trip over such incompatibility obstacles for dependencies that are plain pathetic. I would place myself in the shoes of your customer, and say "altering the host OS is not an option, we need to fix the problem on our end". Even if you have real dependencies on stuff only WebLogic 9.2 gives you, maybe you should revisit the justification for depending on these non-portable things.

Another idea: your error msg seem to point to Java NIO (new I/O) problems. Is there a way you could configure WebLogic to stay clear of NIO, thus possibly bypassing the error?
0
 
arober11Commented:
Hi

Technically Java 1.5 is out of free support, see:

http://java.sun.com/javase/downloads/index_jdk5.jsp
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now