Sending attachments is very slow

Posted on 2010-01-08
Last Modified: 2013-12-09

a user at our company has problems with sending mails with attachments. It takes some time to send the mail, which is strange because it's a new pc, and for instance on my pc (which is old) it takes maybe 2 seconds to send a mail with an 2 MB attachment. We're using also Mcafee Enterprise 8.7.0i

I've already checked that the speed of the network card is the same as on the switch port.
Question by:jvuz
    LVL 11

    Expert Comment

    Check the file is corrupt or infected with virus, check the limitation for attachment size on email server & then check the Mcafee antivirus settings.If antivirus firewall is installed so please properly configure it.Also check the settings on your email client which are using by that user.Sometime user change that settings.Please check the space on your computer.    
    LVL 22

    Expert Comment

    and if you disable  Mcafee Enterprise 8.7.0i ? does the performance change ?
    LVL 22

    Author Comment

    I'll check both suggestions. Thanks you in advance. I'll keep you posted.

    LVL 11

    Expert Comment

    Its a problem with either your mail server or your configuration. You might try enabling SMTP logging per to see if the log file will give you more information about how it fails.

    I'm using v1.5 under XP Pro SP2 with a 1.5MB DSL line. My anti-virus program does not check any messages I send. I just sent a 2,569KB PDF file as an attachment without any problem. It grew to 3521KB due to the base64 encoding. mailnews.tcptimeout is at the default value of 60 seconds.


    Two things to try:

    1) Reconfigure your antivirus program to NOT scan outbound messages.

    2) Reset the timeout setting. Menu Path:
    [In Windows]: Tools | Options, or
    [In OSX]: Thunderbird | Preferences, or
    [In *nix]: Edit | Preferences
    .. then Advanced | Network & Disk Space
    Set the "Connection timeout: [XX] seconds" option to something larger than its default of 60 seconds.

    If this doesn't help, please do start your own new thread, giving as much detail as possible, including what you have already tried to fix the problem. Of great help is to include the full and exact text of any error message you may receive.
    LVL 22

    Accepted Solution

    I've solved by setting both the port on the switch and then NIC to 100/half (speed/duplex). I'll close this question. Thanks everyone for trying to help.

    Featured Post

    What Should I Do With This Threat Intelligence?

    Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

    Join & Write a Comment

    By the time you finish reading this article, you may have already lost all your money because you don't know the simple steps to securing your BitCoin wallet. BitCoin is an incredible invention. It is a decentralized currency system, which is the…
    It is only natural that we all want our PCs to be in good working order, improved system performance, so that is exactly how programs are advertised to entice. They say things like:            •      PC crashes? Get registry cleaner to repair it!    …
    Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
    Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…

    746 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now