cannot run (without crashing) an originally 32-bit application in 64-bit environment

The Visual Studio 2008 Visual C sharp project was created in a 32-bit version of Vista Premim no problem.

Have upgraded the o/s to Windows 7 64-bit.

The issue appears to be the .ocx libarary.  This is a 32-bit 3rd party compile / build.

In order to have VS2008 compile -- I needed to install the .ocx a slightly different way in order to have registered in memory (see by VS2008 referencing libarary).

cd \windows\syswow64
regsvr32 C:\my3rdPartyOCX.ocx

(get a registered ok prompt box confirming registerd ok)

i..e. force an initial register (on my development system) to utilise the wow64 compatibility for setting up .ocx libraries.

The original Windows WinForm project compiles -- just that when I run the application ... and get to the WinForm that use the .ocx library, the system crashes and indicates that the library is not registered.

Have changed within VS2008 the Compile configuration settings from any cpu to x86 -- including the installer project build configs.

Any further thoughts on a solution to this are very much apprieated :-)
amillyardAsked:
Who is Participating?
 
rajvjaConnect With a Mentor Commented:
Have you set the platform target in vs 2008 project?
0
 
amillyardAuthor Commented:
have applied and double-checked that links recommendations -- am getting the same expetion error as follows:

COMException was unhandled
Class not registered (Exception from HRESULT:0x80040154 (REGDB_E_CLASSNOTREG))

When this happens, the debugger stops at the .ocx registration scripting in code -- have to then press stop debugging in order to get back into VS 2008 editor.
0
 
amillyardAuthor Commented:
rajvja: just got to work now :-)))

I think I updated the same place you are referring too above ... the properties tab ... Platform Target was still set to any CPU ... although had manually and saved all the other places in project to x86 as indicated.
0
 
amillyardAuthor Commented:
awesome response  timing (within 2 minutes or writing question).

excellent 'spot on' solution

and apprieated the follow up to confirm configuration.

well done rajvja :-))
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.