Nagios NRPE error, shared libraries; glibc 2.5 or greater.

I have 100% inherated systems and we are moving to a new set of servers, monitoring via nagios. I understand that versions of NRPE can be out of sync so I've ran the same versions as currently in use (plugins-1.4.13 and nrpe-2.12). No errors but can only relate this message: configure: WARNING: LIBS="-lcrypt " CPPFLAGS=""

The daemon is not running under xinetd. Current nodes do not have /etc/services with nrpe listed and the process is running as: nagios 9179 1 0 Jan06 ? 00:00:12 /usr/local/bin/nrpe -c /etc/nrpe.cfg -d


When trying to start in the same fashion from the installation as documented, the following error in full: nrpe: error while loading shared libraries: requires glibc 2.5 or later dynamic linker

I've checked both nodes and any references to glibc shows version 2.3 on both, but is able to run on the current nodes.
Current: Linux localhost 2.4.21-37.0.1.ELsmp #1 SMP Wed Jan 11 18:44:17 EST 2006 i686 i686 i386 GNU/Linux
New: Linux localhost 2.6.9-89.0.11.ELsmp #1 SMP Mon Aug 31 11:01:10 EDT 2009 i686 i686 i386 GNU/Linux

I'm not a seasoned *nix person. Seems that there is a library that it either can't see/load or something makes it want a different version. I've checked up2date for any updated packages and it doesn't show anything to be updated nor lists version 2.5.

Anyone have any thoughts/ideas?

Thanks.
mmcc0912Asked:
Who is Participating?
 
elf_binCommented:
That's right, nrpe says it needs glibc 2.5 or greater.  You can easily verify this with ldd nrpe (or whatever the binary is called) this'll list all the linked libraries the binary will call.
If I understand you correctly, you don't have glibc 2.5 or greater installed.  So you have two choices:
1) Install glibc 2.5 or greater (that can be a real pain as so many things use glibc).
2) Re-compile nrpe to link it against your current installation.

Hope this helps.
0
 
nociSoftware EngineerCommented:
Are you realy sure glibc is 2.3 on linux 2.6?
Appearantly the nrpe image is built on a system that has 2.5.. or the plugins are built there... BTW you need a matching set for your new system. It may be a different version from the old.
The protocol between the nagios server & the nrpe just transfers a string and you should be able to use older (or newer) plugins w.r.t. the server used.

Are the nrpe install kits built for your distribution?
AFAIK you dont run nrpe from xinit daemon but natively as a daemon.
There should be a startscript in /etc/init.d   (/etc/init.d/nrpe?) to start the daemon. The daemon runs permanently.

/etc/services is a file that allows for name/number translation for (udp/tcp) ports.  It's up to a server to use it or not, or to use a default if no value is provided.  (5666 is the default).



0
 
mmcc0912Author Commented:
I guess I don't understand why the new server complains when the nrpe versions are working on the older ones, even running 2.3.  After reading some last night I understand that yes, an attempt to upgrade would probably be devistating...  ldd reports, not a dynamic executable.  

According to up2date, 2.3 is current and the .so files reflect it also.  The nrpe source is the extracted files that were under the old admins profile on the nagios server.  I copied the files and ran the configure and installation on the destination server.  From what I have done with this, it looks like they are downloaded and not via up2date/yum if I'm following you right.  There isn't an nrpe under init.d, it looks like it's being ran manually from the cmdline.  The only files are in the locations of; /usr/local/nagios/bin/nrpe, /etc/xinetd.d/nrpe and /opt/nrpe-2.12/src/nrpe.  If this is true, as expected, I'll need to set that up for obvious reasons....  Thanks for the short info on xinetd, it's something that I haven't bridged into yet...

Overall, I had come to the conclusion that I am hopeful that a lower version of nrpe will run on the system and be acceptable by the nagios server.  While it still doesn't make sense to me why these are this way, ultimately 'it is what it is'....  Last question from the newbie in regards to this, is there an uninstall process to remove the 2.12 or just remove the /usr/local/nagios/* files and install the other version?  


Thanks much...
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
nociSoftware EngineerCommented:
Well RHEL is a little older on some libraries.. (Gentoo uses 2.9 for quite some time already)

If you installed by hand... (make uninstall from the directory you built it in, or remove the directories under /usr/local/nagios...) if you installed it with an RPM (preferable) then you can remove it with rpm.

use http://rpm.pbone.net/ to search for those rpm's... (they also have them for nrpe..)
0
 
Duncan RoeSoftware DeveloperCommented:
My distribution comes with glibc 2.9, so 2.3 and even 2.5 are really quite old (Slackware 13.0).
As long as you use the package manager, there should not be a problem upgrading glibc. 2.x will contain backward compatibility with 2.y where x > y.
0
 
elf_binCommented:
If you're using RHEL, get nrpe from here: http://dag.wieers.com/rpm/packages/nagios-nrpe/
Otherwise just build from source and link against whatever libraries you have installed (I checked the source docs & NRPE says it only requires TCP wrappers & xinetd)

Hope this helps.


0
 
mmcc0912Author Commented:
OK, wanted to take something out of the equation, that is not to use what the previous admin had on the nagios server.  I downloaded the current (same) versions of plugins and nrpe, removed the /usr/local/nagios/ directory and ran configure/make/etc again.  It's happy.  I think there was something from the source files that the previous guy did or something.  Even running configure/make/etc it had something that made it think it needed that library set?  

Thanks all for your help.  
0
 
mmcc0912Author Commented:
Don't copy what someone else had and expect that it's always the correct source to use..
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.