can't run compiled QT apps on windows

Posted on 2010-01-08
Last Modified: 2013-11-23

I am using QT Creator 1.3.0 Based on QT 4.6 on Windows XP
My application compiles but when I try to run it from the command prompt I get
"The application has failed to start because mingwm10.dll wasn ot found. Re-installing the application may fix this problem"

Things I've tried:
1. reinstalling MinGW and adding C:\MinGW\Bin to my environment variables. RESULT: same thing
2. looked for mingwm10.dll on the internet and tried to place it in C:\WINNT\System32 RESULT: this solves this error but then another comes up saying theres a missing gcc_lib or something which made me beleive this is not the right way to fix this.
3. Tried to follow these instructions but couldn't because I could not find the file mkspecs they are talking about.

How do I fix this?
Question by:NewtonianB
    LVL 17

    Accepted Solution

    Put gcc_lib, gcc bin folder includes into system32 too, what was exactly gcc_lib message?
    LVL 11

    Assisted Solution

    Get a copy of depends from

    Use it to find out what your program needs and whether it has found them.

    Normally all the dlls should be either in the directory where the executable resides or somewhere on the %PATH%
    LVL 17

    Expert Comment

    You can also run dependecy walker on mingwm10.dll to find out what that DLL needs and put them also on %PATH% or as I said simply in Windows or system32 folder near mingwm10.dll

    Author Comment

    Thanks CSecurity, cup.

    So i used dependency app and its telling me its now missing

    Where do I find these?
    LVL 17

    Expert Comment

    Should be in QT or GCC installation, do a search on C:\ driver to find them and then put them in C:\Windows\System32 or Windows folder itself

    Author Comment

    I looked for the files on my C Drive and found them to be all in C:\Qt\2009.05\qt\bin
    I had added this to my environment variables but it still wouldnt worl because C:\WINNT\System32 was specified before C:\Qt\2009.05\qt\bin in the Environment path.
    Fixed! Thanks alot
    LVL 17

    Expert Comment

    You are welcome, glad it's fixed

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Training Course: Java/J2EE and SOA

    This course will cover both core and advanced Java concepts like Database connectivity, Threads, Exception Handling, Collections, JSP, Servlets, XMLHandling, and more. You'll also learn various Java frameworks like Hibernate and Spring.

    Article by: SunnyDark
    This article's goal is to present you with an easy to use XML wrapper for C++ and also present some interesting techniques that you might use with MS C++. The reason I built this class is to ease the pain of using XML files with C++, since there is…
    Many modern programming languages support the concept of a property -- a class member that combines characteristics of both a data member and a method.  These are sometimes called "smart fields" because you can add logic that is applied automaticall…
    The viewer will learn how to use and create keystrokes in Netbeans IDE 8.0 for Windows.
    The viewer will be introduced to the technique of using vectors in C++. The video will cover how to define a vector, store values in the vector and retrieve data from the values stored in the vector.

    761 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    7 Experts available now in Live!

    Get 1:1 Help Now