• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1120
  • Last Modified:

Login scripts not working between domains with a trust

We recently acquired a company and have since created a two way trust to allow access to servers between the companies. Recently we had a few users switch offices and noticed a strange issue.

If a user from domain A takes their laptop with them to this new office and signs in everything works as it should. They can log in and get their drives mapped through login script as set in their AD properties.

However if the user attempts to log into a computer that was originally a member of domain B but selects domain A from the login dropdown box they can still log in but their login scripts do not map.

This is the same for a user in domain B. Logging into domain b from a domain b computer the login scripts will run. Logging into domain B from a domain A computer they do not run.

As far as troublshooting I have made sure that the domain controllers can be pinged from both end successfully. I have tested running %logonserver%/netlogon and it brings me to the correct scripts location. I have tried double clicking one of the bat files in that location and it runs and maps the drives correctly.

I dont think this is a DNS related issue otherwise it wouldnt work at all for any computers. Hopefully someone wiser than myself will have something for me.
0
Joseph Daly
Asked:
Joseph Daly
1 Solution
 
Joseph DalyAuthor Commented:
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now