Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 824
  • Last Modified:

spamassasin reject emails

hi,

i have exim configured to go spam checks, now whenever i send a mail from google/hotmail the first conditiion specified here rejects the mail, with this error

Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 550 550-Message content rejected (SPAM score=5.0) id=1NTGeL-0007yT-4d; See
550 http://support.serverdomain.com (state 18).

Can anyone suggest how do i rectify this, currently i have disabled this condition, the full spam config is on the attachment

deny
   spam = nobody
    condition = ${if eq{$ACL_SPAM_ACTION_BATCH}{reject} {1}{0} }
    message = Message content rejected (SPAM score=$spam_score) id=$message_exim_id; \
             See http://support.serverdomain.com
  logwrite = spam_rejected (score $spam_score): $spam_report




 ### SPAM CHECKS
  #deny
  #  spam = nobody
  #  condition = ${if eq{$ACL_SPAM_ACTION_BATCH}{reject} {1}{0} }
  #  message = Message content rejected (SPAM score=$spam_score) id=$message_exim_id; \
  #            See http://support.serverdomain.com
  #  logwrite = spam_rejected (score $spam_score): $spam_report

  warn
    condition = ${if or{{ eq{$ACL_SPAM_ACTION_BATCH}{reject} } \
                        { eq{$ACL_SPAM_ACTION_BATCH}{tag} } \
                       } {1}{0} }
    set ACL_SPAM_RESULT = ham
    spam = nobody
    set ACL_SPAM_RESULT = spam
    add_header = X-New-Subject: {SPAM?} $h_Subject:

  warn
    condition = ${if or{{ eq{$ACL_SPAM_ACTION_BATCH}{reject} } \
                        { eq{$ACL_SPAM_ACTION_BATCH}{tag} } \
                       } {1}{0} }
    add_header = :at_start:X-Server-BorderMail-Spam-Status: \
                 ${if eq {$ACL_SPAM_RESULT}{spam}{spam}{not spam}}, score=$spam_score, policy=$ACL_SPAM_ACTION_BATCH\
                 ${if def:spam_report {, \n\t$spam_report}}
    logwrite = spam_$ACL_SPAM_RESULT (score $spam_score)\
               ${if def:spam_report {: $spam_report}}

  warn
    condition = ${if eq{$ACL_SPAM_ACTION_BATCH}{off} {1}{0} }
    add_header = :at_start:X-Server-BorderMail-Spam-Status: not scanned
    logwrite = spam_notscanned
  #########################


  discard
    message = Message silently dropped (TMP-ACL)
    condition = ${if match {$h_X-Envelope-To:}{email@domain\.net}}

  accept

  # End of acl_check_data

Open in new window

0
krisdigitx
Asked:
krisdigitx
1 Solution
 
ravenplCommented:
Have You already disabled the 2010 SA bug?
Add
score FH_DATE_PAST_20XX 0
to /etc/mail/spamassassin/local.cf
and restart spamassassin
0
 
krisdigitxAuthor Commented:
cool that seems to fix it.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now