• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 669
  • Last Modified:

tap0 device loses ip address after restarting openvpn service

I need my tap0 virtual ethernet device to keep it's assigned ip address after restarting the openvpn service.  Every time I restart the service i have to issue the "ifconfig tap0 192.168.8.5" command.  I have created a script that only has that command and if the service runs it after restarting that would work too.

OS: RHEL 5.4
0
SRG041808
Asked:
SRG041808
  • 2
  • 2
1 Solution
 
vikas_madhusudanaCommented:
you can probable put this script as a startup script
0
 
vikas_madhusudanaCommented:
or edit

/etc/sysconfig/network-scripts/ifcfg-eth0 or eth1

DEVICE=eth0
BOOTPROTO=none
ONBOOT=yes
NETWORK=192.168.8.0
NETMASK=255.255.255.0
IPADDR=192.168.8.5
USERCTL=no
0
 
SRG041808Author Commented:
I already have it as a start up script when the machine boots.

If I edit my ifcfg-eth0 file that would mess up my eth0 interface.

eth1 is a physical adapter but isnt being used at this time...

I tried to create a ifcfg-tap0 file and restarted the network and openvpn services and then my vpn wouldnt work.... maybe something to do with the device id?
0
 
SRG041808Author Commented:
If the service goes down it will be my my own doing.. i'll just have to remember to configure the tap device after...
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now