• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 401
  • Last Modified:

How do I configure which version of Java Tomcat 6 will use?

The original setup was Tomcat 6 installed on a Windows 2003 server with Java 1.5, we had to upgrade the Java to 1.6 for an application but Tomcat is still pointing to Java 1.5. When I do a java -version it is 1.6, how do I force Tomcat to use java 1.6?
0
peddiesd
Asked:
peddiesd
  • 2
  • 2
1 Solution
 
icenickCommented:
Dear peddiesd,

You need to setup JAVA_HOME environment variable to show to the new path of java.

Here is a link how to setup the JAVA_HOME variable.

http://wso2.org/project/wsas/java/1.1/docs/setting-java-home.html

I hope this is the case.
0
 
peddiesdAuthor Commented:
Thanks Icenick

I set the Java_home variable but still was a no go. I ended up reinstalling Tomcat which seemed to fixed the issue.
0
 
icenickCommented:
Did you restart you pc after setting Java_HOME? Did you restart tomcat?

Anyway, I am glad that it worked after all.
0
 
peddiesdAuthor Commented:
Tomcat yes, server no, but I did also do a 'set' from the command line for JAVA_HOME.
0
 
TolomirAdministratorCommented:
yes I did also reinstall tomcat, but checkout the file tomcatw.exe in the bin folder, I think you can configure the proper jave dll there.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now