• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1068
  • Last Modified:

How do I resolve ORA-00132: error

I tried starting up my development database and got the following error:

C:\>sqlplus "/as sysdba"

SQL*Plus: Release 10.2.0.4.0 - Production on Fri Jan 8 11:33:33 2010

Copyright (c) 1982, 2007, Oracle.  All Rights Reserved.

Connected to an idle instance.

SQL> startup
ORA-00119: invalid specification for system parameter LOCAL_LISTENER
ORA-00132: syntax error or unresolved network name 'LISTENER_GABJOS'
SQL> quit
Disconnected

So I tried starting my listener and got the following output:

C:\>lsnrctl start

LSNRCTL for 32-bit Windows: Version 10.2.0.4.0 - Production on 08-JAN-2010 11:34
:15

Copyright (c) 1991, 2007, Oracle.  All rights reserved.

TNS-01106: Listener using listener name LISTENER has already been started

Can someone help me to figure out what is wrong and fix it.
0
sikyala
Asked:
sikyala
1 Solution
 
sdstuberCommented:
your database is expecting to find a listener called

'LISTENER_GABJOS'

you can either start a listener with that name,  or clear the LOCAL_LISTENER parameter so your db will use the default listener named, simply "LISTENER"
0
 
slightwv (䄆 Netminder) Commented:
Check your listener.ora to see if you have a listener called: LISTENER_GABJOS

if so: lsnrctl start LISTENER_GABJOS
0
 
sikyalaSenior Database AdministratorAuthor Commented:
I checked and I don't have a listener called LISTENER_GABJOS

I have no idea where it is gettingt that name. the database name is GABJOS


listener contents

LISTENER =
  (DESCRIPTION_LIST =
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
      (ADDRESS = (PROTOCOL = TCP)(HOST = BAH506246Sikya1.resource.ds.bah.com)(PORT = 1521))
    )
  )


SID_LIST_LISTENER =
  (SID_LIST =
    (SID_DESC =
      (SID_NAME = PLSExtProc)
      (ORACLE_HOME = C:\oracle\product\10.2.0\db_1)
      (PROGRAM = extproc)
    )

Open in new window

0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
slightwv (䄆 Netminder) Commented:
No idea where it was set but it's no big deal.  Since the listener is the defaule, just unset the parameter.

startup nomount;
alter system set local_listener='' scope=spfile;
alter database open;
0
 
sdrouinsCommented:
did you check on your tnsname.ora file if listener was correct?
by default this file is in C:\Oracle\ORACLE10G\network\ADMIN
0
 
sikyalaSenior Database AdministratorAuthor Commented:
i can't even startup nomount

SQL> startup nomount
ORA-00119: invalid specification for system parameter LOCAL_LISTENER
ORA-00132: syntax error or unresolved network name 'LISTENER_GABJOS'
0
 
slightwv (䄆 Netminder) Commented:
ok then....  see if enough of the instance is up to perform the following:
SQL> create pfile='c:\mypfile.ora' form spfile;

If that works, edit the file you just created and startup the database with the pfile and re-create the spfile.

If that fails, see if you can trick it into starting then change the parameter:
http://www.shutdownabort.com/errors/ORA-00119.php
0
 
sikyalaSenior Database AdministratorAuthor Commented:
found this entry in my tnsnames.ora

LISTENER_GABJOS =
  (ADDRESS = (PROTOCOL = TCP)(HOST = BAH506246Sikya1.resource.ds.bah.com)(PORT = 1521))
0
 
slightwv (䄆 Netminder) Commented:
Does the server BAH506246Sikya1.resource.ds.bah.com exist?
0
 
sikyalaSenior Database AdministratorAuthor Commented:
yes
0
 
sikyalaSenior Database AdministratorAuthor Commented:
yes slightwv i was able to create a pfile. should what should i edit the pfile to:
pfile contents:

gabjos.__db_cache_size=406847488
gabjos.__java_pool_size=20971520
gabjos.__large_pool_size=4194304
gabjos.__shared_pool_size=163577856
gabjos.__streams_pool_size=0
GABJOS._first_spare_parameter=1
*.aq_tm_processes=0
*.audit_file_dest='C:\ORACLE\PRODUCT\10.2.0\ADMIN\GABJOS\ADUMP'
*.background_dump_dest='C:\ORACLE\PRODUCT\10.2.0\ADMIN\GABJOS\BDUMP'
*.compatible='10.2.0.1.0'
*.control_files='C:\ORACLE\PRODUCT\10.2.0\ORADATA\GABJOS\CONTROL01.CTL','C:\ORACLE\PRODUCT\10.2.0\ORADATA\GABJOS\CONTROL02.CTL','C:\ORACLE\PRODUCT\10.2.0\ORADATA\GABJOS\CONTROL03.CTL'
*.core_dump_dest='C:\ORACLE\PRODUCT\10.2.0\ADMIN\GABJOS\CDUMP'
*.db_block_size=8192
*.db_domain=''
*.db_file_multiblock_read_count=16
*.db_name='gabjos'
*.db_recovery_file_dest_size=2147483648
*.db_recovery_file_dest='C:\oracle\product\10.2.0/flash_recovery_area'
*.dispatchers='(PROTOCOL=TCP) (SERVICE=gabjosXDB)'
GABJOS.event='10411 trace name context forever, level 1'
*.job_queue_processes=10
*.local_listener='LISTENER_GABJOS'
*.nls_length_semantics='BYTE'
*.open_cursors=300
*.pga_aggregate_target=200278016
*.processes=150
*.remote_login_passwordfile='EXCLUSIVE'
*.resource_manager_plan=''
*.sga_target=603979776
*.undo_management='AUTO'
*.undo_retention=900
*.undo_tablespace='UNDOTBS1'
*.user_dump_dest='C:\ORACLE\PRODUCT\10.2.0\ADMIN\GABJOS\UDUMP'

Open in new window

0
 
slightwv (䄆 Netminder) Commented:
delete the line: *.local_listener='LISTENER_GABJOS'
0
 
sikyalaSenior Database AdministratorAuthor Commented:
I deleted the entry and when i type create spfile from pfile i get file created response. But when i try to bounce the database i get the same error. I backed up the spfile before I created spfile from pfile and stored backup in another directory. But when I go to the ORACLE_HOME/dbs directory the spfile is not there. I tried creating the spfile from pfile several times but the file is not appearing in the directory even though at the command line it says file created.
0
 
slightwv (䄆 Netminder) Commented:
Just to clarify the steps:
- created pfile:  create pfile='c:\myp.ora' from spfile;
-after editing file, started database with edited pfile: startup pfile='c:\myp.ora';
-just for grins, verify the entry is gone: show parameter local
- create new spfile:  create spfile from pfile='c:\myp.ora';

I'll need to look into why the spfile isn't defaulting to the dbs directory.
0
 
sikyalaSenior Database AdministratorAuthor Commented:
When I explicitedly created the spfile by giving it a directory path it successfully created the spfile. I did a search and it was writing the spfile to a database directory under oracle directory.
0
 
sikyalaSenior Database AdministratorAuthor Commented:
When I explicitedly created the spfile by giving it a directory path it successfully created the spfile. I did a search and it was writing the spfile to a database directory under oracle directory.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now