Windows Integrated Authentication not working

Posted on 2010-01-08
Last Modified: 2013-12-08

I have an Intranet where Windows Integrated Authentication is working fine on all my Windows XP workstations. This also works on a few Windows 7 computers I've tested on. I'm preparing a deployment of windows 7 using WDS, MDT, AIK. When I deploy a computer from WDS/MDT users on that computer cannot open the intranet website without having to type their username and password (basic authentication). With the same user on my own Windows 7 laptop there's no problem, so I'm guessing the problem is on the deployed workstation. Windows Integrated Authentication is enabled in Windows Internet Explorer 8 so what else could be the problem.

Same group policies are applied in all scenarios

I have no ideas, so please help.
Question by:ReneDK
    LVL 21

    Expert Comment

    LVL 5

    Expert Comment

    I've only had a quick look at your problem.  Off the top of my head I would try the following::

    Run IE8 in XP compatibility mode.  If you still have the request for Username and password then its the firewall on the Windows 7 machine stopping machine info getting to the Intranet server.

    Try this as its a quick try and see what happens.  Hope this helps.


    LVL 15

    Accepted Solution

    You probably just need to setup these intranet sites in the local intranet zone in the IE settings.  Within Internet Explorer, go to Tools-->Internet Options.  Then Security-->Local Intranet--> Sites-->Advanced.  Add your website to this list.

    You can then click on 'Custom Level' while still highlighting the Local Intranet Zone, and scroll all the way down and choose to choose automatic logon for websites in that zone.

    You should then be able to hit your intranet site without being prompted.

    Author Comment

    Hmm... after deploying 4 computers with the problem I was unable to reproduce it on a virtual pc. I'm gonna try again. If unsuccesfull I will try your solutions monday when I get back at work. Thanks so far.

    Author Comment

    I was able to reproduce the problem again. It seems like problem is solved in the way Tray896 suggested (haven't tested the others). I'm gonna publish a GPO and get back monday.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Course: HTML5 Mobile App Development with PhoneGap

    PhoneGap can help you leverage your already existing HTML5, JavaScript, and CSS skills in order to create and deploy cross-platform mobile apps.This program comprehensively covers HTML5 mobile app development from top to bottom.

    I annotated my article on ransomware somewhat extensively, but I keep adding new references and wanted to put a link to the reference library.  Despite all the reference tools I have on hand, it was not easy to find a way to do this easily. I finall…
    Several part series to implement Internet Explorer 11 Enterprise Mode
    The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
    The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    14 Experts available now in Live!

    Get 1:1 Help Now